[Cost Control] Fte redraw is very choppy when tapping next or back

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::Cost Control
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: rpribble, Assigned: mai)

Tracking

({regression})

unspecified
2.1 S6 (10oct)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [2.1-Daily-Testing], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8497775 [details]
Logcat.txt

Description:
The redraw in the fte when setting up the Data Usage app shows some black flashing and choppy redraw when tapping next or back.

Repro Steps:
1) Update a Flame device to BuildID: 20140930000203
2) Navigate to data usage app
3) Tap next and back a few times through the fte
  
Actual:
Navigating the fte shows black flashes and choppy redraw.
  
Expected: 
All graphic transitions appear smoothly.
  
Environmental Variables:
Device: Flame 2.1 KK (319MB)
BuildID: 20140930000203
Gaia: a00d102abfe8ae15c4fd14771efa2335c6d3b8d9
Gecko: cde28bd9a285
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Notes:
  
Repro frequency: 100%
See attached: Video, logcat
(Reporter)

Comment 1

3 years ago
This issue also occurs on the Flame v2.2 KK.

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140930040206
Gaia: 77ef35f5429bc3dfe9ca192b9aacc3c0bf8857de
Gecko: 7c24470b6b3a
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Navigating the fte shows black flashes and choppy redraw.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → affected
Flags: needinfo?(pbylenga)
QAWanted for branch check to see if this is a regression.
Flags: needinfo?(pbylenga)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?]
Tested with Shallow Flash

This bug repro's on Flame KK builds: Flame 2.2 KK, Flame 2.1 KK

Actual Results: Black flashing occurs when navigting backwards through the Cost Control FTE.

Repro Rate: 4/4

Environmental Variables:
Device: Flame Master KK
BuildID: 20141001060621
Gaia: a23d2c490b39c4699c9375e25c4acdf396a2fa85
Gecko: 835ef55e175e
Version: 35.0a1 (Master) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141001060122
Gaia: b327c640fea887770d011a127e349838b3b44724
Gecko: 7359d0d0222d
Version: 34.0a2
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.0 KK

Actual Result: No issues seen navigating forward or backward through Cost Control FTE.

Repro Rate: 0/2

Environmental Variables:
Device: Flame 2.0
BuildID: 20141001060124
Gaia: 8079cba2133e6f5443dba24dad077f7f91e6c978
Gecko: 66c1ea78b6c1
Version: 32.0 (2.0) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
Flags: needinfo?(jmitchell)
Keywords: qawanted → regression
QA Contact: croesch
[Blocking Requested - why for this release]: Regression in a major app + bad UX
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
QA Contact: croesch
triage: bad UX , regression
blocking-b2g: 2.1? → 2.1+
(Assignee)

Updated

3 years ago
Assignee: nobody → mri
(Assignee)

Comment 6

3 years ago
Created attachment 8498820 [details] [review]
patch v1.0

Hi,
IMO, the problem is related with the transition between the FTE steps, for this reason I've removed them, this way the app is more aligned with the FTU.

Regards
Attachment #8498820 - Flags: review?(salva)
(Assignee)

Comment 7

3 years ago
Hi Rachel,
would you mind testing if the patch resolve the black flashes, I cannot reproduce it with my device.

Regards,
Marina
Flags: needinfo?(rpribble)
Comment on attachment 8498820 [details] [review]
patch v1.0

If we are going to remove the progress bar and the transitions, let's do it but with UX approval and not leaving dead code. What I mean is to remove code instead of avoiding the transition.
Attachment #8498820 - Flags: review?(salva) → review-
(Reporter)

Comment 9

3 years ago
Hi Marina,
I am still seeing this issue occur on today's v2.1 and v2.2 with a full flash. 
We are currently waiting for a respin of today's v2.2 and I can recheck the build after we receive it to see if any changes have occurred.

Environmental Variables:
Device: Flame 2.1 KK (319mb)
BuildID: 20141002000202
Gaia: 94dcc25f2e34a4900ea58310c26be52bcb089161
Gecko: baaa0c3ab8fd
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device:  Flame 2.2 KK (319mb)
BuildID: 20141002040202
Gaia: 191d805f4911628d37a8a90a1e23a6013995138f
Gecko: 2399d1ae89e9
Gonk: n/a
Version: 35.0a1 (2.2)
Firmware: v180 
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Navigating the fte shows black flashes and choppy redraw.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(rpribble) → needinfo?(pbylenga)
The request is to test the patch locally.  Rachel can you retest?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(pbylenga) → needinfo?(rpribble)

Updated

3 years ago
QA Contact: ddixon
Unable to provide a Regression Window. 

Issue DOES occur in earliest Flame KK (v180) 2.2 build. 

(Tested with 319 MB memory and Shallow Flash.)

Device: Flame Master
Build ID: 20140904171737
Gaia: de59e0c3614dd0061881fe284e9f2d74fa0d1d5d
Gecko: 8703c1895505
Version: 35.0a1 (Master)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Issue DOES NOT occur in the JB base image (v123).

Device: Flame Master
Build ID: 20141003070740
Gaia: a8a6eed2ba9d66239aac789b9ee4900f911c73cb
Gecko: 388e101e75c8
Version: 35.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Comment on attachment 8498820 [details] [review]
patch v1.0

Marina, I'm clearing the flag for review, please review the comments on GitHub and ask for my review when you're done.
Attachment #8498820 - Flags: review-
(Assignee)

Comment 13

3 years ago
Comment on attachment 8498820 [details] [review]
patch v1.0

Updated the pr with your comments
Attachment #8498820 - Flags: review?(salva)
Comment on attachment 8498820 [details] [review]
patch v1.0

Working fine. Thank you Marina.
Can QA apply this patch locally in order to verify if the anomalous behavior is solved?
Attachment #8498820 - Flags: review?(salva) → review+
Keywords: verifyme
master: c78d27d08700610ef3f31a0865ad66dd3bb294a6
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S6 (10oct)
Please request Gaia v2.1 approval on this patch when you get a chance.
status-b2g-v2.2: affected → fixed
Flags: needinfo?(mri)
(Assignee)

Comment 17

3 years ago
Comment on attachment 8498820 [details] [review]
patch v1.0

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature
[User impact] if declined: Bad UX, a visual defect on the fte transitions.
[Testing completed]: On device
[Risk to taking this patch] (and alternatives if risky): Low risk
[String changes made]: No
Attachment #8498820 - Flags: approval-gaia-v2.1?(release-mgmt)
Flags: needinfo?(mri)
Attachment #8498820 - Flags: approval-gaia-v2.1?(release-mgmt) → approval-gaia-v2.1+

Updated

3 years ago
QA Contact: ddixon
Issue is verified fixed in Flame 2.2, 2.1 builds (Full Flash, nightly).

Actual Results: UI in Usage app transitions/redraws without abrupt flashing. 

Note: tested with 512 and 319 MB memory settings. 

Device: Flame Master
Build ID: 20141015040201
Gaia: 5f1f0960ae9d22acf2a324ad37a48174d6df87f6
Gecko: 62f0b771583c
Version: 36.0a1 (Master)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.1
Build ID: 20141015001201
Gaia: 379ea4c9dd6d3f8ca2f79ce59c15f6afe6e557c3
Gecko: 4853208cb48a
Version: 34.0 (2.1)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Reporter)

Comment 20

3 years ago
Clearing ni since the issue was verified by Duane.
Flags: needinfo?(rpribble)
You need to log in before you can comment on or make changes to this bug.