"ReferenceError: Task is not defined" when installing an app from another app

RESOLVED FIXED in Firefox 35

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: myk, Assigned: marco)

Tracking

({regression})

Trunk
Firefox 35
x86
Mac OS X
regression
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Trying to install an app from another app fails with this error in the JS Console:

> Timestamp: 2014/09/30, 14:47:34
> Error: ReferenceError: Task is not defined
> Source File: resource://app/modules/WebappManager.jsm
> Line: 90
(Assignee)

Comment 1

4 years ago
Created attachment 8497812 [details] [diff] [review]
Patch
Attachment #8497812 - Flags: review?(myk)
(Reporter)

Updated

4 years ago
Attachment #8497812 - Flags: review?(myk) → review+
No tests for this?
(Reporter)

Comment 3

4 years ago
(In reply to :Gavin Sharp [email: gavin@gavinsharp.com] from comment #2)
> No tests for this?

Hmm, I thought we did have a test (in the suite that we're working to enable in automation over in bug 899707), but I just checked, and it looks like we don't.

Marco: can you add a test for this?

In the meantime, this run should at least ensure we haven't broken anything in the browser:

https://tbpl.mozilla.org/?tree=Try&rev=1843090935ad
Flags: needinfo?(mar.castelluccio)
(Assignee)

Comment 4

4 years ago
There's a bug opened to add such a test (bug 1006394), I had some problems with it that may have gone away in the meantime (the transition to WebIDL may have fixed them).

Can we land this and track the addition of a test in bug 1006394?
Flags: needinfo?(mar.castelluccio)
(Reporter)

Comment 5

4 years ago
(In reply to Marco Castelluccio [:marco] from comment #4)
> Can we land this and track the addition of a test in bug 1006394?

Yes, that's reasonable, given the circumstances.
Assignee: nobody → mar.castelluccio
Keywords: regression
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/a237f4594a2e
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
Just fyi, I had to add the bug number to the commit message to meet the commit hook requirements.
https://hg.mozilla.org/mozilla-central/rev/a237f4594a2e
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 35
Blocks: 1078777
Flags: qe-verify-
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.