If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Video texture example doesn't work in chrome

RESOLVED WORKSFORME

Status

Developer Documentation
General
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: peter.i.ehrlich, Assigned: Nobody's working on this, feel free to take it)

Tracking

(Depends on: 1 bug)

Details

(Reporter)

Description

3 years ago
What did you do?
================
open in chrome 37.0.2062.124 

https://developer.mozilla.org/samples/webgl/sample8/index.html

via
https://developer.mozilla.org/en-US/docs/Web/WebGL/Animating_textures_in_WebGL

What happened?
==============
index.html:1
WebGL: drawElements: texture bound to texture unit 0 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering or is not 'texture complete'. Or the texture is Float or Half Float type with linear filtering while OES_float_linear or OES_half_float_linear extension is not enabled. index.html:1
WebGL: INVALID_OPERATION: generateMipmap: level 0 not power of 2 or not all the same size 

many times.  Black render context.

What should have happened?
==========================
Rotating cube with video.

Is there anything else we should know?
======================================
Assignee: nobody → eshepherd
Component: General → General
Product: Mozilla Developer Network → Developer Documentation
Thanks for the bug report. Moving to Developer Documentation product.
Assignee: eshepherd → nobody
Status: UNCONFIRMED → NEW
Depends on: 1076893
Ever confirmed: true
Whiteboard: [specification][type:bug]
Works for me in Chromium and Opera under Ubuntu.
Please re-open if this still happens.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.