Closed Bug 1075301 Opened 5 years ago Closed 5 years ago

Open resultset in new tab appears to have stopped working correctly

Categories

(Tree Management :: Treeherder, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jfrench, Assigned: jfrench)

References

()

Details

Attachments

(1 file)

"open resultset in new tab" appears to have stopped working correctly in the past several days.

To reproduce:
o go to dev, stage or production (or locally w/latest master)
o click on any resultset to "open this resultset in new tab"
eg. Sep 30, 2014 9:14:19 AM - cbook@mozilla.com 2ae57957e4

Expected:
o a new tab with just that one resultset
http://localhost:8000/app/index.html?repo=mozilla-central&revision=2ae57957e4bb

Observed:
o you get a new tab which fleetingly shows that, then transforms to
http://localhost:8000/app/index.html?repo=mozilla-central&revision=2ae57957e4bb#/jobs?repo=mozilla-central

...basically it always appends "#/jobs?repo=mozilla-central
" to the URL, and in doing so wrongly builds a full list of all resultsets in the new tab.

I am curious if anyone else is seeing it.
:lightsofapollo can reproduce it also. Perhaps related to all the recent work to remove the repo bar from the nav bar, but that is purely a guess on my part.
Yeah I can repo (tried on prod)
Priority: P2 → P1
(In reply to Jonathan French (:jfrench) from comment #1)
> :lightsofapollo can reproduce it also. Perhaps related to all the recent
> work to remove the repo bar from the nav bar, but that is purely a guess on
> my part.

It turns out the missing repo bar is an unrelated issue. Now entered as bug 1076040.
I think I have a fix for this, and it will likely be a part of PR219 for bug 1076040 since it is closely related. I will include and flag this bug for review once I am sure.
Assignee: nobody → tojonmz
Status: NEW → ASSIGNED
Attached file treeherder-ui-PR#219
Please see the above PR for review and status. It encompasses fixes for both this bug and bug 1076040.
Attachment #8501232 - Flags: review?(cdawson)
Commits pushed to master at https://github.com/mozilla/treeherder-ui

https://github.com/mozilla/treeherder-ui/commit/0ace84f6d8fa3aa961882bd9ebf0eba11875cf76
Bug 1075301 - Open correct resultset url in new tab

https://github.com/mozilla/treeherder-ui/commit/41e441f221a9f4322399a024220db9fb13d273c5
Merge pull request #219 from tojonmz/missing-watched-navbar

Bug 1076040, 1075301- Ensure watched repo navbar appears on initial page load, open resultset in new tab
Verified fixed and working correctly on dev in both Firefox and Chrome.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Attachment #8501232 - Flags: review?(cdawson) → review+
Status: RESOLVED → VERIFIED
Commits pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/5c45f5fc98b4ba590ebd4edad63278c789d8450f
Bug 1075301 - Open correct resultset url in new tab

https://github.com/mozilla/treeherder/commit/d17478d69bbe9f54cd10d56c34b2d9eed21fb3a3
Merge pull request #219 from tojonmz/missing-watched-navbar

Bug 1076040, 1075301- Ensure watched repo navbar appears on initial page load, open resultset in new tab
You need to log in before you can comment on or make changes to this bug.