Closed browser windows reappear as no-responsive windows when switching desktops in a multi-desktop environment

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: jenner, Assigned: Dan M)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

Using multiDesk as a multi desktop manager sometimes I see that previously
closed browser windows reappear after switching the desktop and back. Those
browser windows never refresh and not respond to keyboard and mouse (but are
active as tasks - can be selected in the taskbar). The Mozilla Quick Launch
never see this windows ("Exit Mozilla" is enabled having some - >=1 - of this
"phantom windows"). The presence of this windows seems to produce no problem to
the other fully functional browser windows. When the Mozilla Quick Launch were
close the "phantom windows" disappears.

Reproducible: Sometimes
Steps to Reproduce:
1. Open browser window and start navigating sites.
2. Open links in new windows (I always use the command in the right mouse button
menu)
2.1 Click on links that opens new windows (using Javascript or different target
attributes in <A> tag)
3. Close some windows (both the windows that are created by the operation in
steps 2.x, and the windows where you have started creating new windows)
4. Switch desktop and back

Actual Results:  Sometimes you find previously closed windows reappered as task
in the taskbar but they doesn't refresh or respond.

Expected Results:  Mozilla should close definitively his browser windows (like
any other application that I currently use).

I frequently have this kind of problem when using http://www.mailgate.org/ and
http://www.easyusenet.com/ newsgroup browsing services. I often access to both
services in the same time in different browser windows. I usually have an open
window on the messages list and I open into a new window the single messages (2
o 3 at the same time).
Reporter: Your build is old. Please try a more recent build:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-talkback.zip
(as always, be sure to delete your old Mozilla directory before installing the
new one)

Dupe of bug 99645?
(Reporter)

Comment 2

17 years ago
The problem is still there using the 2001103003 build. I think this bug hasn't
correlations with bug 99645.
Reporter: Have you tried a fresh profile? You can manager/create profiles with
"mozilla.exe -profilemanager".

-> XP Apps 
Assignee: asa → pchen
Component: Browser-General → XP Apps
QA Contact: doronr → sairuh
danm?
Assignee: pchen → danm
QA Contact: sairuh → jrgm

Comment 5

17 years ago
Reporter, are you still seeing this on more recent builds?
Have you tried this with a new profile?

Also, is multiDesk a free (or available in shareware) program so that we may
test this?

Thanks.
Mike: Though I don't use MultiDesk, you can get it here:
http://www.siliconrealms.com/mdeskinfo.htm
(shareware)
CC: moku_@hotmail.com

Mike: It doesn't do much good to ask a question (comment #5) if you won't be
around to hear the response ;).

Comment 8

16 years ago
No response from reporter. ->WFM ?
(Reporter)

Comment 9

16 years ago
I'm still trying to reproduce the problem in a way that can be precisely
described. I see that introducing the tabbed browsing in Mozilla has really
reduced the number of times this problem happen... but sometimes happens (right
now about one time per release...).
Using Mozilla 0.9.9 it happened only one time and now, using the 1.0RC1, I got
any problem.
Is it better to spend no time around this problem?

Comment 10

16 years ago
Sounds like we don't get rid of the window completely. We must be leaving the
old browser window in memory somewhere. Normal severity.
Severity: trivial → normal

Comment 11

16 years ago
Worksforme Build ID: 2002042608 (0.9.9+) trunk Windows 98.

Reporter, are you still seeing this problem?

Comment 12

16 years ago
just downloaded Multidesk to try this out (multidesk 3.90a and mozilla 1.0RC3 on
win2k), and while I can't reproduce the exact problem described, Mozilla windows
definitely behave very strangely in Multidesk. When switching to a different
"desktop", Mozilla windows tend to stay where they are (i.e. they act like the
"appear on all desktops" option is set, although it isn't.

Don't know what to do with this - I'm not sure it's necessarily a bug in
Mozilla, but Mozilla windows do seem to behave differently from most other
Windows app windows in terms of Multidesk. I don't see how this could be "fixed"
without working with the developers of Multidesk.

Comment 13

16 years ago
problem i saw seems to be bug 62310.  can't reproduce the closed windows thing,
reporter hasn't replied again for more than 30 days.  resolving WFM.

reporter (or anyone): if you can reproduce this bug with a recent build of
mozilla, please reopen this bug. thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.