Enable the Georgian Decoder

VERIFIED FIXED in mozilla0.9.7

Status

()

VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: giasher, Assigned: nhottanscp)

Tracking

Trunk
mozilla0.9.7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 7 obsolete attachments)

(Reporter)

Description

17 years ago
 
(Reporter)

Comment 1

17 years ago
Created attachment 55726 [details] [diff] [review]
patch for Georgian charset (GEOSTD8) enabling

Comment 2

17 years ago
Not much to go on here. Dup of bug 49192?

Comment 3

17 years ago
ahh sorry - didn't see the patch. adding keyword.
Keywords: patch
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: REF: enabling Georgian → Enable the Georgian Decoder

Comment 4

17 years ago
Comment on attachment 55726 [details] [diff] [review]
patch for Georgian charset (GEOSTD8) enabling

1. we don't need to change
registryhack2.h (I file a seperate bug to remove it from cvs)
2. 
 geostd8 is not listed under http://www.iana.org/assignments/character-sets
 do you plan to register it ? should we call it x-geostd8 untill it got registered ?
Attachment #55726 - Flags: review+

Comment 5

17 years ago
I cannot apply the patch to my system. Please use
cvs diff -u to create the patch.
(Reporter)

Comment 6

17 years ago
Created attachment 56418 [details] [diff] [review]
"cvs diff -u" format patch (by '?' signed new files needed - they are ready)

Comment 7

17 years ago
Comment on attachment 56418 [details] [diff] [review]
"cvs diff -u" format patch (by '?' signed new files needed - they are ready)

r=ftang. Don't check in the registryhack2.h part. It is not needed.
Attachment #56418 - Flags: review+

Comment 8

17 years ago
nhotta- can you help me to get sr= ? and land this when I on vacation ? Thanks
Assignee: ftang → nhotta
(Assignee)

Comment 9

17 years ago
No, the new file nsGEOSTD8ToUnicode.cpp cannot be found in the attachments.
It has to be also attached here.
(Assignee)

Comment 10

17 years ago
Please attach the following files for review:
? intl/uconv/ucvlatin/geostd8.uf
? intl/uconv/ucvlatin/geostd8.ut
? intl/uconv/ucvlatin/nsGEOSTD8ToUnicode.cpp
? intl/uconv/ucvlatin/nsGEOSTD8ToUnicode.h
? intl/uconv/ucvlatin/nsUnicodeToGEOSTD8.cpp
? intl/uconv/ucvlatin/nsUnicodeToGEOSTD8.h

(Reporter)

Comment 11

17 years ago
Created attachment 58126 [details] [diff] [review]
adding
(Reporter)

Comment 12

17 years ago
Created attachment 58129 [details] [diff] [review]
adding intl/uconv/ucvlatin/geostd8.ut (*.uf is upper - 58126)
(Reporter)

Comment 13

17 years ago
Created attachment 58133 [details] [diff] [review]
adding intl/uconv/ucvlatin/nsGEOSTD8ToUnicode.cpp
(Reporter)

Comment 14

17 years ago
Created attachment 58134 [details] [diff] [review]
adding intl/uconv/ucvlatin/nsGEOSTD8ToUnicode.h
(Reporter)

Comment 15

17 years ago
Created attachment 58135 [details] [diff] [review]
adding intl/uconv/ucvlatin/nsUnicodeToGEOSTD8.cpp
(Reporter)

Comment 16

17 years ago
Created attachment 58136 [details] [diff] [review]
adding intl/uconv/ucvlatin/nsUnicodeToGEOSTD8.h
(Assignee)

Comment 17

17 years ago
Comment on attachment 58136 [details] [diff] [review]
adding intl/uconv/ucvlatin/nsUnicodeToGEOSTD8.h

r=nhotta

The comment in the file,
/**
 * A character set converter from Unicode to GEOSTD8.
 *
 * @created	    4/26/1999
 * @author  Frank Tang [ftang]
 */
Please remove if those are not written by Frank.
(Assignee)

Updated

17 years ago
Attachment #58136 - Flags: review+
(Assignee)

Comment 18

17 years ago
Comment on attachment 58134 [details] [diff] [review]
adding intl/uconv/ucvlatin/nsGEOSTD8ToUnicode.h

r=nhotta

please remove the comment if this was not written by Frank.
/**
 * A character set converter from GEOSTD8 to Unicode.
 *
 * @created	    4/26/1999
 * @author  Frank Tang [ftang]
 */
Attachment #58134 - Flags: review+
(Assignee)

Comment 19

17 years ago
Comment on attachment 58133 [details] [diff] [review]
adding intl/uconv/ucvlatin/nsGEOSTD8ToUnicode.cpp

r=nhotta
Attachment #58133 - Flags: review+
(Assignee)

Comment 20

17 years ago
Comment on attachment 58135 [details] [diff] [review]
adding intl/uconv/ucvlatin/nsUnicodeToGEOSTD8.cpp

r=nhotta
Attachment #58135 - Flags: review+
(Assignee)

Updated

17 years ago
Attachment #55726 - Attachment is obsolete: true
(Assignee)

Comment 21

17 years ago
Comment on attachment 58126 [details] [diff] [review]
adding

This is auto generated data file, I cannot review this.
(Assignee)

Comment 22

17 years ago
Comment on attachment 58129 [details] [diff] [review]
adding intl/uconv/ucvlatin/geostd8.ut (*.uf is upper - 58126)

This is auto generated data file, I cannot review this.
(Assignee)

Comment 23

17 years ago
Let me combine new files into one patch.
(Assignee)

Comment 24

17 years ago
Created attachment 58588 [details] [diff] [review]
Georgian charset (GEOSTD8) enabling, new files
(Assignee)

Updated

17 years ago
Attachment #58126 - Attachment is obsolete: true
Attachment #58129 - Attachment is obsolete: true
Attachment #58133 - Attachment is obsolete: true
Attachment #58134 - Attachment is obsolete: true
Attachment #58135 - Attachment is obsolete: true
Attachment #58136 - Attachment is obsolete: true
(Assignee)

Comment 25

17 years ago
Comment on attachment 58588 [details] [diff] [review]
Georgian charset (GEOSTD8) enabling, new files

r=nhotta
Attachment #58588 - Flags: review+
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.7
(Assignee)

Comment 26

17 years ago
I can do the Mac build change. But I will wait until the new files are checked 
in.
Comment on attachment 56418 [details] [diff] [review]
"cvs diff -u" format patch (by '?' signed new files needed - they are ready)

rs=brendan@mozilla.org
Attachment #56418 - Flags: superreview+
Comment on attachment 58588 [details] [diff] [review]
Georgian charset (GEOSTD8) enabling, new files

sr=brendan@mozilla.org

/be
Attachment #58588 - Flags: superreview+
(Assignee)

Comment 29

17 years ago
One question about the proposed order in menu (navigator.properties).
Why not alphabetical order as Armenian -> Georgian?

Comment 30

17 years ago
As for a section to place the new encoding item, SE & SW Asian section
looks like the right place since this section already contains Armenian,
which can be classfied into SW Asia in a broad sense of the term
"Asia" as sometimes applied. We need to alphabetize this section since
some items were added earlier without alphabetizing them. 

More on the mail compose menu issue later. 
(Reporter)

Comment 31

17 years ago
'm beleive that new section (e.g. "SE Europe") will be very appropriate for 
Turkish, Armenian, Georgian (may be other ones) which are considered es 
Eouropean countries in a broad sense.
As for alphabetical order, it's on your convenience, but [me] suppose it will 
be possible and better for users to NOT USE the same order IN THE LOCALIZED 
versions of corresponding (messenger, navigator, editoroverlay, charsetoverlay 
DTD, etc.) files. 
(Assignee)

Comment 32

17 years ago
Checked in files except navigator.properties, .dtd files in the patch are not 
needed.
navigator.properties has to be edited later to inlcude Georgian.
Cc to ylong, yokoyama.
(Assignee)

Comment 33

17 years ago
I am going to add geostd8 after armscii-8 for now and we can open a new bug for 
the ordering issue.
(Assignee)

Comment 34

17 years ago
>we can open a new bug for the ordering issue.
bug 113300
(Assignee)

Comment 35

17 years ago
Created attachment 60211 [details] [diff] [review]
Added geostd8 before armscii-8.
(Assignee)

Comment 36

17 years ago
The comment was wrong, it actually added geostd8 after armscii-8.

Comment 37

17 years ago
Comment on attachment 60211 [details] [diff] [review]
Added geostd8 before armscii-8.

/r=yokoyama
Attachment #60211 - Flags: review+
(Assignee)

Comment 38

17 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 39

17 years ago
Gia, I am sorry to raise this issue now but is "geostd8" a
preferred encoding for mail as opposed to UTF-8? Surely you 
thought about using UTF-8 for Georgian. Are there any alias names
for "geostd8". Do Mac and Windows have their own encodings?
Also I don't see a reference where geostd8 is defined? Can you
point me to one?
(Reporter)

Comment 40

17 years ago
hi, situation is quit complex:
1) GEOSTD8 is an official National Standard (unfortunately Unicode "non-
sequential") and used by most of (~80%) users and organizations within Georgia.
2) Cause of it RFC was sent to IETF and will be send to IANA after December 15. 
See - http://lists.w3.org/Archives/Public/ietf-charsets/2001OctDec/0008.html 
3) definition is here - http://lists.w3.org/Archives/Public/ietf-
charsets/2001OctDec/att-0007/01-draft-giasher-charset-geostd8.txt
4) About UTF8 - my Unicode compliant font package will be published in nearest 
10 days (covering Basic Latin, Western and Central European, Russian, Georgian).
5) As an alias in Linux used "Georgian-ps"
6) MAC and WIN have no [official] supporting to Georgian codepages yet.
due to size additional info (links) will be sented separately.

Comment 41

17 years ago
Gia, thanks for the additional info. I had no objection about
including GEOSTD8 in the display menu for Browser/Mail/Editor.
My onyl reservation has to do with Mail Compose window menu. Our
policy there is to include normally accepted standard encoding only.

Let's hope that there will be no Windows or Mac specific encodings
for Georgian and GEOSTD8 will be all we need except Unicode.

As for the alias name, "Georgian-ps", is this mostly used for 
printing. Do we need to add to the charsetalist names list, or would it
suffice it to add it to a file like Unix.js?
(Reporter)

Comment 42

17 years ago
Kat, it's impossible to not agree with your policy.

Above-mentioned Georgian Language Pack will include also Georgian System fonts 
for Windows and possible Unix Console fonts which becemes a key tool for 
Georgianization and GEOSTD8 is considered as Win Encoding.
 
Seems that's only standard approved for Georgian (excluding single-byte DOS 
corresponding with same sequence as GEOSTD8 and beginning from DEC 128) and it 
seems GEOSTD8 becames international after registering by IANA.  Also, 'm forced 
to use that standard for any localization of 16-bit applications and WIN9x 
itself(using 8-bit encoding) as it is National Standard. 

That 8-bit System fonts - http://www.gia.ge/fonts/winfonts.htm already works 
for Mozilla in Windows 9x - http://www.gia.ge/scrshots/ns_6/ns6.htm 
and for Windows 9x itself - http://www.gia.ge/windows_9x/windows_9x.htm

Sure, policy must be towards UTF8/Unicode. That's situation for nowadays.
If another (better from my point of view) standard will be registered that will 
be other case.

Alias only for Unix is enough.  99.9% uses Windows environment [in Georgia].

Comment 43

17 years ago
Verified as fixed in 12-28 trunk build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.