Closed Bug 1075387 Opened 5 years ago Closed 5 years ago

crash in mozilla::a11y::ProxyAccessible::Shutdown()

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect, critical)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: viorela, Assigned: tbsaunde)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file, 1 obsolete file)

This bug was filed from the Socorro interface and is 
report bp-88757f5d-e495-4f3f-96c8-e7d802141001.
=============================================================

Several tests are failing because the phone is crashing with this crash signature, at random steps: 
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.mozilla-central.ui.functional.smoke/16/HTML_Report/
I'm able to reproduce the crash locally too, when running one of the automated tests that are failing on jenkins - test_add_new_contact.py
Repro rate: 5 out of 5 times.

Regression range, based on b2g-i builds:
Last working:
application_buildid: 20140930043330
application_changeset: 4355feecf4bd
application_display_name: B2G
pplication_name: B2G
application_repository: https://hg.mozilla.org/integration/b2g-inbound
application_version: 35.0a1
build_changeset: 3a2947df41a480de1457a6dcdbf46ad0af70d8e0
device_firmware_date: 1412078489
device_firmware_version_incremental: eng.cltbld.20140930.080119
device_firmware_version_release: 4.4.2
device_id: flame
gaia_changeset: 09ffd07964de1ad15d7ab34ab89c78bdf223605a
gaia_date: 1412074270
platform_buildid: 20140930043330
platform_changeset: 4355feecf4bd
platform_repository: https://hg.mozilla.org/integration/b2g-inbound

First failing:
application_buildid: 20140930064322
application_changeset: f4e8988b3881
application_display_name: B2G
application_name: B2G
application_repository: https://hg.mozilla.org/integration/b2g-inbound
application_version: 35.0a1
build_changeset: 3a2947df41a480de1457a6dcdbf46ad0af70d8e0
device_firmware_date: 1412086327
device_firmware_version_incremental: eng.cltbld.20140930.101157
device_firmware_version_release: 4.4.2
device_id: flame
gaia_changeset: 09ffd07964de1ad15d7ab34ab89c78bdf223605a
gaia_date: 1412074270
platform_buildid: 20140930064322
platform_changeset: f4e8988b3881
platform_repository: https://hg.mozilla.org/integration/b2g-inbound

Pushlog: http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=4355feecf4bd&tochange=f4e8988b3881

I was able to reproduce a crash manually, 1 out of 5 times.
STR:
1. Full flash your phone with latest master KK build
2. launch Contacts app

#Expected results:
Contacts app is properly launched

#Actual results:
The phone is crashing  when Contacts app is launched 

I'll attach the logcat of the failure seen in test_add_new_contact.py
Attached file logcat (obsolete) —
Attached file logcat
Attachment #8498003 - Attachment is obsolete: true
When I've been able to reproduce the failure manually, I wasn't using a fresh build, but one on which I already ran test_add_new_contact.py several times.

I tried to reproduce the crash manually again after doing full flash and I wasn't able to reproduce the failure again. I tried ~ 10 times.
I manage to reproduce a crash with the same behaviour using:

Gaia-Rev        77ef35f5429bc3dfe9ca192b9aacc3c0bf8857de
Gecko-Rev       https://hg.mozilla.org/integration/mozilla-inbound/rev/355d3c412278
Build-ID        20140929153558
Version         35.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20140929.185931
FW-Date         Mon Sep 29 18:59:42 EDT 2014
Bootloader      L1TC10011800



My only issue is that I got a different crash signature:
https://crash-stats.mozilla.com/report/index/826a1217-a3c6-4929-b979-395d82141001
Regression range base on mozilla-inbound build:
Last working: 
Gaia-Rev        4d663b1f7d63e4d3d69c181a58f21b38145044b2
Gecko-Rev       https://hg.mozilla.org/integration/mozilla-inbound/rev/3a2cf29a629f
Build-ID        20140929112958
Version         35.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20140929.144044
FW-Date         Mon Sep 29 14:40:55 EDT 2014
Bootloader      L1TC10011800

First failing: 
Gaia-Rev        4d663b1f7d63e4d3d69c181a58f21b38145044b2
Gecko-Rev       https://hg.mozilla.org/integration/mozilla-inbound/rev/6abcab74130a
Build-ID        20140929115059
Version         35.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20140929.150733
FW-Date         Mon Sep 29 15:07:44 EDT 2014
Bootloader      L1TC10011800
Tomcat As this is breaking all our automation runs can you help us with a revert?

From the for commits in that log we think https://hg.mozilla.org/integration/mozilla-inbound/rev/a11adf1705ec is the one that's breaking our builds
Flags: needinfo?(cbook)
Assignee: nobody → trev.saunders
Blocks: 982842
This issue has been fixed by the back out.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
FYI I just have seen a crash with this signature on Windows 7 64bit build with e10s enabled
crashreport
https://crash-stats.mozilla.com/report/index/9bb31f2e-6a5c-453b-9979-8c10c2141106

BuildID:
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141105030203 CSet: 62990ec7ad78

Story: Took a screenshot with snagit.exe (screenshot tool) after that I saw an acessebility prompt flicker and the content process crashed.
After the crash the pref
browser.tabs.remote.autostart.disabled-because-using-a11y is set to true, disabling e10s.
I opened a separate bug 1100602 for martin's comment 10, as it's for FF Desktop and started occuring after this bug was resolved.
You need to log in before you can comment on or make changes to this bug.