Images are cut off after the 8192nd pixel, causing facebook.com emoticons not to appear

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: cwiiis, Unassigned)

Tracking

Trunk
x86
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8498045 [details]
Facebook emoticons image

I've only tested this on Windows in Nightly with e10s enabled, but it would appear that images are cut off after the 8192nd vertical pixel. Unfortunately, Facebook.com chat emoticons are stored in a single, incredibly tall image: https://fbstatic-a.akamaihd.net/rsrc.php/v2/yP/r/7SrH40Z4RBE.png (also attached for reference)

This causes the most common emoticons (which are inexplicably all stored towards the bottom of the image) to not appear in Facebook chat messages.

Chrome is not affected.
(Reporter)

Comment 1

3 years ago
Internet Explorer is also not affected.
(Reporter)

Comment 2

3 years ago
Tested on Linux without e10s, works fine.
Seems like this could be D2D related. (max texture size)
Is it a regression?
(Reporter)

Comment 5

3 years ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #4)
> Is it a regression?

I'm pretty certain facebook messenger emoticons have worked in the past on Windows, but I don't know what's changed their side, so don't really know if this is a regression or not.
(Reporter)

Comment 6

3 years ago
Looks like this has been fixed now - I'm seeing all sorts of other similar bugs, but not this specific one.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.