add-ons that depend on npm modules with test files fail to pass when `jpm test` is run

RESOLVED DUPLICATE of bug 1077372

Status

Add-on SDK
General
P1
normal
RESOLVED DUPLICATE of bug 1077372
3 years ago
3 years ago

People

(Reporter: erikvold, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

When `jpm test` is run sdk/test/runner tries to run the test files for an add-on's dependencies too, which it should not even try to do, but because it is trying to do this at the moment `jpm test` is always failing because sdk/test/runner is detecting the extra test files but failing to load them properly (it's using the wrong path for some reason)
Depends on: 963226
Priority: -- → P1
Blocks: 1034413
Blocks: 915376
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1077372
You need to log in before you can comment on or make changes to this bug.