Discussion Forum: mozilla.release-engineering

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: pmoore, Assigned: achavez)

Tracking

Details

(Whiteboard: {Waiting on response from Giganews/google], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
List Name: mozilla.dev.release-engineering
List Admin: pmoore@mozilla.com, 

Short Description:
For all release engineering discussion at Mozilla.

Long Description:
There are a ton of tools and systems in place to stand up the Release Engineering pipeline at Mozilla. Most of the custom development is done in python, with many integrations to other open source tools, in order that Mozillians worldwide can be empowered to contribute to the Mozilla product line, trusting in the Release Engineering systems to build, test and ship their software in a reliable and reproducible fashion.

We'd love to welcome you to our forum, and hear about your great ideas. We hope that you will feel encouraged to influence and shape the way Release Engineering is done at Mozilla, and not be afraid to join in with any discussion. And most importantly, we look forward to coding with you! =)

Justification / Special Instructions:

See bug 1074797 which explains the rationale behind this new discussion forum.
(Reporter)

Updated

4 years ago
Blocks: 1074797
If this is about RE best practices and doing RE at Mozilla, it should probably be called mozilla.release-engineering. If it's about development of code and systems for RE, then mozilla.dev.release-engineering is the right name. If it's both, I'd probably go for the former name.

Once that question is resolved, server-ops can implement.

Gerv
Assignee: gerv → server-ops
(Reporter)

Comment 2

4 years ago
I tend to favour mozilla.release-engineering, since it is both dev and operational work, but I'll summon the team, and get back with a definitive answer.
I have no problem with you using mozilla.release-engineering. Makes sense to me.

Gerv
Summary: Discussion Forum: mozilla.dev.release-engineering → Discussion Forum: mozilla.release-engineering
(Reporter)

Comment 4

4 years ago
I've sent an email to the team asking them to vote here:
http://www.easypolls.net/poll.html?p=542d157fe4b09149347e1ce7
(In reply to Pete Moore [:pete][:pmoore] from comment #4)
> I've sent an email to the team asking them to vote here:
> http://www.easypolls.net/poll.html?p=542d157fe4b09149347e1ce7

I'll note that there were already 4 votes for dev- in bug 1074797 made by commenting in the bug, and none for the alternative. I'd consider the issue resolved.
(Reporter)

Comment 6

4 years ago
Thanks guys for all your interest and support!

The votes went 7 to 2 on the issue in favour of release-engineering@lists.mozilla.org, so this appears to be the (comfortable) winner, even considering comments in favour of "dev-" prefix in bug 1074797.

http://www.easypolls.net/poll.html?p=542d157fe4b09149347e1ce7

Server-ops: please go ahead with this.

Many thanks!
Pete
(Reporter)

Updated

4 years ago
Flags: needinfo?(gerv)
Why needinfo me? I've said it's fine for server-ops to go ahead with mozilla.release-engineering.

Gerv
Flags: needinfo?(gerv)
(Reporter)

Comment 8

4 years ago
(In reply to Gervase Markham [:gerv] from comment #7)
> Why needinfo me? I've said it's fine for server-ops to go ahead with
> mozilla.release-engineering.
> 
> Gerv

Sorry Gerv, I ni'd the wrong party.
Flags: needinfo?(server-ops)
(Reporter)

Comment 9

4 years ago
(In reply to Pete Moore [:pete][:pmoore] from comment #6)

> Server-ops: please go ahead with this.

Hi Server Ops,

Do you have an idea when you might have time to set this up, or do you need any further information in order to progress this request?

Many thanks in advance,
Pete
(Reporter)

Updated

4 years ago
Flags: needinfo?(justdave)
(Reporter)

Comment 10

4 years ago
I'm not sure how to progress this bug - would be great if we could land before http://python.ie/pycon/2014 is over (tomorrow), as there may be some interest from contributors there.
I haven't touched these in years.  But my access to do so doesn't seem to have been revoked, so if the MOC folks don't get it I probably can, but that's their responsibility these days.

Who will be managing the moderator queue for this group?  Need to know that before it can be set up.  Even if it's an unmoderated group, there will be items getting stuck in the moderator queue (non-members posting, spam, etc) and Mailman will send you emails to tell you what's stuck there and ask for decisions. Each list needs a person to deal with that.
Flags: needinfo?(justdave)
(Reporter)

Comment 12

4 years ago
Thanks Dave! I am happy to be the moderator (pmoore@mozilla.com) - or *if allowed* release@mozilla.com can be the moderator.

release@mozilla.com is the private internal email address for the Release Engineering group. The new discussion forum / email will be also for contributors - so is a wider group than release@mozilla.com, which will be a subscriber to the new discussion forum.

Pete
Flags: needinfo?(server-ops)
(Reporter)

Updated

4 years ago
Flags: needinfo?(justdave)
(Reporter)

Comment 13

4 years ago
Hi guys,

Is it possible to get an update on this?

Many thanks,
Pete
Server-ops normally triage these and assign them to someone. Not sure why that hasn't happened yet. Bumping to "major".

Gerv
Severity: normal → major

Updated

4 years ago
Assignee: server-ops → achavez
(Assignee)

Comment 15

4 years ago
Discussion form has been created. Please allow 24-48 hours turnaround from giganews/google.
Status: NEW → ASSIGNED
Flags: needinfo?(justdave)
Whiteboard: {Waiting on response from Giganews/google]
(Reporter)

Comment 16

4 years ago
Awesome!

Many thanks Ashlee, Rick, Gervase, Dave!
(Reporter)

Comment 17

4 years ago
(In reply to Ashlee Chavez [:Ashlee] from comment #15)
> Discussion form has been created. Please allow 24-48 hours turnaround from
> giganews/google.

There seem to be two lists set up:
  * https://lists.mozilla.org/listinfo/release-engineering (expected)
  * https://lists.mozilla.org/listinfo/mozilla.release.engineering (not expected)

They both have separate administration pages:
  * https://lists.mozilla.org/admin/release-engineering
  * https://lists.mozilla.org/admin/mozilla.release.engineering

Maybe this is required for the newsgroup mirroring, but I just wanted to check. My concern is if this introduces a second email address, e.g.:

  * release-engineering@lists.mozilla.org (working perfectly, thank you)
  * mozilla.release.engineering@lists.mozilla.org (untested)

I haven't tried writing to the second email address, in case it reaches real people, and confuses them, since we planned for the first email address only.

Maybe the above setup is expected, just want to double check that we don't end up with two different lists.

Thanks,
Pete
Flags: needinfo?(achavez)
(Reporter)

Comment 18

4 years ago
Please note, regarding the above two admin interfaces, I can login and change the settings of both, and the settings are not in sync - so they appear to be two genuinely separate accounts.

  * https://lists.mozilla.org/admin/release-engineering
  * https://lists.mozilla.org/admin/mozilla.release.engineering
(In reply to Pete Moore [:pete][:pmoore] from comment #18)
>   * https://lists.mozilla.org/admin/release-engineering

This is what should exist...

>   * https://lists.mozilla.org/admin/mozilla.release.engineering

This one is bogus. Can we remove it, please? :-)

Gerv

Comment 20

4 years ago
(In reply to Gervase Markham [:gerv] from comment #19) 
> >   * https://lists.mozilla.org/admin/mozilla.release.engineering
> 
> This one is bogus. Can we remove it, please? :-)
 Done

[root@mailman2.mail.corp.phx1 bin]# ./rmlist -a mozilla.release.engineering
Removing list info
Removing private archives
Removing private archives
Removing public archives
mozilla.release.engineering public archives not found as /var/lib/mailman/archives/public/mozilla.release.engineering.mbox

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(achavez)
Resolution: --- → FIXED
(Reporter)

Comment 21

4 years ago
Created attachment 8513359 [details]
Screen Shot 2014-10-29 at 10.53.03.png

I changed the settings of the forum a couple of times to allow non-members to post messages (see attached screenshot - I set it to "Accept", but later it seems to get reset back to "Hold"). This means, sometime later, if somebody posts a message, it will get quarantined.

The reasons I wish for it to be Accept by default are:
1) The whole team gets the emails by virtue of release@mozilla.com being subscribed to the discussion forum, and therefore are not individually subscribed to the forum
2) Potential contributors may be discouraged from posting messages, if they first have to subscribe to the forum.

Is there a way to prevent this setting from getting overridden?

Many thanks,
Pete
(Reporter)

Comment 22

4 years ago
url I am using to change this setting in comment 21 is: https://lists.mozilla.org/admin/release-engineering/privacy/sender
(Reporter)

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I couldn't get that setting to work on a list that I admin in the past either.
(Reporter)

Comment 24

4 years ago
Thanks ed for the tip in #releng - was able to set regular expression ^.* as a whitelist for non-members, essentially automatically accepting all non-members, and thus not needing to hit the fallback option setting in comment 21.

Tested, and works.

Another one bites the dust. =)
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
At least a while back, there was some Python script that "regularized" all the list settings, which meant you couldn't persist changes. Perhaps that's the source of the problem here. I was never able to find out much about it or why we actually needed it... Ask ashlee or justdave?

Gerv
You need to log in before you can comment on or make changes to this bug.