Closed Bug 1075455 Opened 7 years ago Closed 7 years ago

[Calendar] month view current day indicator does not advance at midnight

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0M+, b2g-v2.0 wontfix, b2g-v2.0M verified, b2g-v2.1 verified, b2g-v2.2 verified)

RESOLVED FIXED
2.1 S6 (10oct)
blocking-b2g 2.0M+
Tracking Status
b2g-v2.0 --- wontfix
b2g-v2.0M --- verified
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: jocheng, Assigned: evanxd)

References

Details

(Whiteboard: [p=2])

Attachments

(5 files)

+++ This bug was initially created as a clone of Bug #1069792 +++

[Preset]
The system time is 9.19  9:32AM

[Instructions]
1.Yesterday is 9.18,today is 9.19
2.Enter calendar
3.Tap today icon
3.Check calendar in month view

[Expected]
The yellow and blue mark in 9.19

[Error]
The yellow mark in the 9.18 and blue mark in 9.19
Dear Evan

As described in bug 1069792
Please fix this bug dup from bug 1069792.

Thank you!
Flags: needinfo?(evanxd)
blocking-b2g: --- → 2.0M+
Duplicate of this bug: 1069792
Is this device specific?
Flags: needinfo?(jocheng)
Hi Dylan,
QA has verified that this is generic bug, not device specific.
Flags: needinfo?(jocheng)
(In reply to Dylan Oliver [:doliver] from comment #3)
> Is this device specific?

Hi Dylan:
 This is generic bug.

the quick repo. STRs are:
1. Settings -> Date & Time -> un-check "Set automatically"
2. Set current time to 11:58 PM
3. Goto Calendar -> Month view
4. click today (left down corner)
     Date is correct
5. Wait for two minutes, click today again
     Issue happened.
Assignee: nobody → evanxd
Flags: needinfo?(evanxd)
generic bug should be 2.0+
blocking-b2g: 2.0M+ → 2.0+
I confirmed this is easy to reproduce on Flame but I really question that this would be considered a 2.0 blocker at this late stage. 

It is not likely to be a regression from 1.3 and does not appear to be a major usability issue. The much more noticeable blue highlight does function properly and moves to the correct day. It's just the borderline that gets left behind and that problem corrects itself if you restart the app.

We can investigate and fix on master but I'm moving this back to a 2.0 nomination for re-triage.
blocking-b2g: 2.0+ → 2.0?
Summary: [Woodduck][Calendar]The mark show uncorrectly when the time from 18 to 19. → [Calendar] month view current day indicator does not advance at midnight
Target Milestone: --- → 2.1 S6 (10oct)
Comment on attachment 8500296 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24808

Hi Miller,
Could you help to review the patch?
Thanks.
Attachment #8500296 - Flags: review?(mmedeiros)
Comment on attachment 8500296 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24808

nice work! small changes, clean code and fixes the problem.
Attachment #8500296 - Flags: review?(mmedeiros) → review+
Triage group: blocking by incorrect ux behavior.
blocking-b2g: 2.0? → 2.0+
master: 41dc1b534e0f1b8c8be6af05f0eb545f0ad582fc
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Miller, thanks for the review.
Comment on attachment 8501583 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24924

Just the same pull request of https://github.com/mozilla-b2g/gaia/pull/24808. We create this new pull request because of some CI issues.
Attachment #8501583 - Flags: review+
Comment on attachment 8501583 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24924

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): None.
[User impact] if declined: Month view current day indicator does not advance at midnight. So user will see the wrong date after midnight.
[Testing completed]: It works in local, and the unit test works well on try server.
[Risk to taking this patch] (and alternatives if risky): Low, it is a small change(about 12 lines).
[String changes made]: No.
Attachment #8501583 - Flags: approval-gaia-v2.0?(bbajaj)
Does this affect v2.1 as well? If so, please request approval for that as well :)
status-b2g-v2.1: --- → ?
Flags: needinfo?(evanxd)
Flags: needinfo?(evanxd)
Comment on attachment 8501583 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24924

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): None.
[User impact] if declined: Month view current day indicator does not advance at midnight. So user will see the wrong date after midnight.
[Testing completed]: It works in local, and the unit test works well on try server.
[Risk to taking this patch] (and alternatives if risky): Low, it is a small change(about 12 lines).
[String changes made]: No.
Attachment #8501583 - Flags: approval-gaia-v2.1?(bbajaj)
Ryan, thanks for the reminder.
Whiteboard: [p=2]
Duplicate of this bug: 1041167
Comment on attachment 8501583 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/24924

The user impact here is not severe enough to land on 2.0 or block any release here. ALso there is a clear work around here, to avoid this issue when you quite the app.

Given we can still take low risk fixes on 2.1 and we have a few more days for FC approving this.
Attachment #8501583 - Flags: approval-gaia-v2.1?(bbajaj)
Attachment #8501583 - Flags: approval-gaia-v2.1+
Attachment #8501583 - Flags: approval-gaia-v2.0?(bbajaj)
Attachment #8501583 - Flags: approval-gaia-v2.0-
blocking-b2g: 2.0+ → 2.0M?
Needs rebasing for v2.1 uplift. Also, setting v2.0 to wontfix based on comment 21.
Flags: needinfo?(evanxd)
Attached file PR for v2.1 branch
Hi Ryan,
It is the pr for v2.1 branch.
Flags: needinfo?(evanxd)
checkin-needed for the 2.1 branch patch
Hi LuoFan,
Please verify on woodduck. Thanks!
Flags: needinfo?(fan.luo)
blocking-b2g: 2.0M? → 2.0M+
(In reply to Josh Cheng [:josh] from comment #26)
> Hi LuoFan,
> Please verify on woodduck. Thanks!

Please ignore my comment.
Flags: needinfo?(fan.luo)
Merge into v2.0m conflict.

--
Changes to be committed:

	modified:   apps/calendar/test/unit/app_test.js

Unmerged paths:
  (use "git add <file>..." to mark resolution)

	both modified:      apps/calendar/js/app.js
Flags: needinfo?(evanxd)
Hi Kai-Zhen Li,

The [1] commit is for v2.0m branch.

checkin-needed for the v2.0m branch patch

[1] https://bugzilla.mozilla.org/attachment.cgi?id=8504016
Flags: needinfo?(evanxd)
Attached file PR for v2.0m
Will merge it into v2.0m when the tree is opened.
The current closure is for bustage on master. I've gone ahead and merged.

2.0M: https://github.com/mozilla-b2g/gaia/commit/a273ab9c18e9184eb02722b25c73e2ba7680cc09
Ryan, Thanks!
Hi LuoFan,
It's been merged to 2.0M now.
Please verify on woodduck. Thanks!
Flags: needinfo?(fan.luo)
Hi, KTucker&Josh,

  This issue does not exist in the Flame 2.0 and Woodduck 2.0M.

Flame version:
Gaia-Rev        76070c98dd0068324938c79bede50fe6d90bd996
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/a966f9f6e3ac
Build-ID        20141019161201
Version         34.0
Device-Name     flame-kk
FW-Release      4.4.2
FW-Incremental  34
FW-Date         Tue Sep 30 14:06:36 CST 2014
Bootloader      L1TC00011840

Woodduck version:

Gaia-Rev        a273ab9c18e9184eb02722b25c73e2ba7680cc09
Gecko-Rev       e7df4dde2d9dbedee942333d34eaea2afe32bebc
Build-ID        20141017100433
Version         32.0
Device-Name     soul35
FW-Release      4.4.2
FW-Incremental  1413510704
FW-Date         Fri Oct 17 09:52:15 CST 2014
Keywords: verifyme
Clear the needinfo for fan.luo@mgsei.com.
Flags: needinfo?(fan.luo)
Duplicate of this bug: 1093508
Attached video video
This issue has been verified successfully on woodduck 2.0, Flame 2.1 and 2.2
See attachment: 1075455_video.MP4 
Reproducing rate: 0/5
Woodduck2.0 build:
Gaia-Rev        87b23fa81c3b59f2ba24b84f7d686f4160d4e7cb
Gecko-Rev       d049d4ef127844121c9cf14d2e8ca91fd9045fcb
Build-ID        20141125050313
Version         32.0
Flame 2.1 build:
Gaia-Rev        8ae086c39011bc8842b2a19bb5267906fa22345a
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ebbd5c65c3c1
Build-ID        20141124094013
Version         34.0
Flame2.2 build:
Gaia-Rev        aad40f6d6eb8f626c6a20db55b9f00d2e832f113
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/be4ba3d5ca9a
Build-ID        20141124100136
You need to log in before you can comment on or make changes to this bug.