Severe layout and text selection problems with negative margins

RESOLVED WONTFIX

Status

()

Core
Layout
P1
normal
RESOLVED WONTFIX
17 years ago
15 years ago

People

(Reporter: Thomas Hurst, Assigned: Marc Attinasi)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.5+)
Gecko/20011030
BuildID:    2001103003

Having just come up with http://freak.aagh.net/w00t/ (and having it and the CSS
validate), I've found some pretty nasty problems with Mozilla.

With a window approx 1024*768 part of the navbar is hidden behind a white block,
including a link and the p tag's border.

Reducing the size of the window eventually brings the link back.  Increasing the
size results in the title disappearing.

A friend has reproduced this using 0.9.5 via Galeon.

Additionally, the text on the left side of the margin is non selectable.

Reproducible: Always
Steps to Reproduce:
1. Install Mozilla.
2. Go to http://freak.aagh.net/w00t/
3. Sigh.

Actual Results:  Parts of page not shown. Some text not selectable.

Expected Results:  All of page shown. All text selectable.

I upgraded to the latest nightly from one about two days ago, both show the same
problem.

A page also using negative border sizes is at
http://www.w3.org/Provider/Style/URI, which seems fine, text selection and all.

The page is currently set to XHTML 1.1 - that's about the only major difference
I can see (that page uses HTML 4.01). That, and the border around the p tag.

I'll continue fiddling to see if I can make it go away.

Comment 1

17 years ago
Confirming issue with negative margin. Working on reduced test case.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Created attachment 55759 [details]
Transitional HTML reduced test case

Comment 3

17 years ago
Created attachment 55760 [details]
Same Transitional test case with url to background image

Comment 4

17 years ago
Created attachment 55762 [details]
Removing the background references seems to resolve issue
(Reporter)

Comment 5

17 years ago
Yep, I just removed the background from the original site and the problem
disappeared.

In fact, just removing background-attachment: fixed; seemed to resolve it
without any apparant change in behaviour of the background.

That'll do me as a workaround, now you fix the bug *g*

Updated

17 years ago
Target Milestone: --- → mozilla1.0.1
(Assignee)

Comment 6

16 years ago
Moving Mozilla 1.01 bugs to 'future' milestone with priority P1

I will be pulling bugs from 'future' milestones when scheduling later work.
Priority: -- → P1
Target Milestone: mozilla1.0.1 → Future
Marking worksforme, since using an actual existing image in that testcase shows
the text above the image, as it should be.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.