Add "Deactivate and mark all content as spam" action for mods on user profiles

RESOLVED FIXED in 2014Q4

Status

P3
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: philipp, Assigned: rrosario)

Tracking

unspecified
2014Q4

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=contributor c=questions p=2 s=2014.19)

(Reporter)

Description

4 years ago
Since many of the spammers we see at the site routinely open numerous questions and/or replies, it would be of benefit if there is a "one-click" solution for moderators on a user's profile to deactivate the account and mark all produced content as spam at the same time.
Thanks for filing this! I've been meaning to file this bug for a long time but as "deactivate user and delete all posts". But now we have the mark as spam feature so we need those spam posts to train our spam detector. :)
Status: UNCONFIRMED → NEW
Component: General → Users and Groups
Ever confirmed: true
This sounds good to me. Since we are not deleting the content this would be reversible and and probably low risk. I'm assuming that moderators and admins would have this privilege. 

Madalina, are you okay with this?
Flags: needinfo?(mana)
Priority: -- → P3
Whiteboard: u=contributor c=questions p= s=2013.backlog
Target Milestone: --- → Future

Comment 3

4 years ago
(In reply to philipp from comment #0)
> Since many of the spammers we see at the site routinely open numerous
> questions and/or replies, it would be of benefit if there is a "one-click"
> solution for moderators on a user's profile to deactivate the account and
> mark all produced content as spam at the same time.

Right now,  the "mark as spam" feature doesn't include discussion forum and kbforum posts.  See
Bug 1074229 - Add a way to manually mark discussion forum posts as spam

Comment 4

4 years ago
Sounds good to me, let's go for it. Moderators only, of course.
Flags: needinfo?(mana)
We'll try to get to this ASAP, but this quarter doesn't have much 25% time. We might need to sacrifice some time from the forum 2.0 project if we think this is important enough.
Whiteboard: u=contributor c=questions p= s=2013.backlog → u=contributor c=questions p= s=2014.19
Target Milestone: Future → 2014Q4
(Assignee)

Comment 6

4 years ago
Do we want to always mark a user's content as spam when we deactivate them? Or is there a use case for deactivating users and leaving their content as is?

I think this is 2pts. We need to get all the user's questions and answers and set the is_spam flag.
Flags: needinfo?(mana)
Whiteboard: u=contributor c=questions p= s=2014.19 → u=contributor c=questions p=2 s=2014.19
(Assignee)

Updated

4 years ago
Assignee: nobody → rrosario
Hey Ricky, can you comment on what you went with?
Flags: needinfo?(rrosario)
(Assignee)

Comment 9

4 years ago
We'll have both buttons.
Flags: needinfo?(rrosario)
Flags: needinfo?(mana)
(Assignee)

Comment 11

4 years ago
Deployed to prod.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Updated

4 years ago
Depends on: 1088648
(Reporter)

Updated

4 years ago
Duplicate of this bug: 970057
You need to log in before you can comment on or make changes to this bug.