Closed Bug 1075643 Opened 5 years ago Closed 4 years ago

Offer to import Android bookmarks and history during first run experience

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1199859

People

(Reporter: rnewman, Unassigned)

References

(Blocks 1 open bug)

Details

Probably not in such a way that we eliminate the possibility of setting up FxA, but this would be nice to have.

I'm sure Yuan is already addressing this in her mocks, but figured I'd file a bug to track.

If folks think this is worthwhile from a retention and on-boarding standpoint, we should add this to the funnel and prioritize it for a release.
This would be nice to have for sure. Once a user import browsing data, they are more likely to invest in the app.

Richard, could you please specify what types of data can Fennec import and what are the import sources(any browser that is installed on the device?). And how long does it typically take? I assume just a few seconds.

I am planning to surface this option for the Get Started. And it'd be nice to show the themes UX have coordinated with marketing(customization, sync, privacy) while importing the data in the background.
(In reply to Yuan Wang(:Yuan) – Mobile Firefox Design Lead from comment #1)

> Richard, could you please specify what types of data can Fennec import and
> what are the import sources(any browser that is installed on the device?).
> And how long does it typically take? I assume just a few seconds.

Bookmarks and history. This was implemented in Bug 710330.

We merge from the Android system browser. IIRC Chrome writes into this location, too.

We don't have any way to import from third-party apps that don't use the Android system stores. We *can* ask the system how many bookmarks and history items there are.

How long it takes depends on the amount of data. I don't remember it being either exceptionally fast or slow. It's unlikely to be more than a few seconds.

(Sidenote: because this is buried in Settings, it doesn't get a lot of use, and we should test the hell out of it before surfacing it like this.)
Yes. Like Bug 963661 (I havn't retried that in a while)
found this old bug too chenxia, feel free to close if not applicable :)
Flags: needinfo?(liuche)
This will be handled by the A/B test in bug 1199859.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(liuche)
Resolution: --- → DUPLICATE
Duplicate of bug: 1199859
You need to log in before you can comment on or make changes to this bug.