Double search suggestion (with bookmark search keyword?)

RESOLVED DUPLICATE of bug 1096247

Status

()

Firefox
Location Bar
RESOLVED DUPLICATE of bug 1096247
3 years ago
3 years ago

People

(Reporter: djc, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
x86
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8498270 [details]
Screenshot of ugly double suggestion

When I try to search Google using my bookmark search keyword, I get two awesomebar suggestions to search Google instead of one. See screenshot.
(Reporter)

Updated

3 years ago
Flags: needinfo?(bmcbride)

Updated

3 years ago
Blocks: 995091
I cannot reproduce... do you have steps to reproduce on a clean profile?
Flags: needinfo?(bmcbride) → needinfo?(dirkjan)

Comment 2

3 years ago
Created attachment 8500128 [details]
screenshot

STR with clean profile:

1. type "test" in search field and press enter
2. close tab with search result
3. type "test" in address bar

Actual:

3x "Search with Google"

Expected:

1x "Search with Google"

Same result with keyword search instead of search field search.
Bug 1063542 would help with this, thought I suspect it would need to be a bit more lax in matching than just the purpose param for it to actually solve this problem properly.
Depends on: 1063542
(Reporter)

Comment 4

3 years ago
Are the STR in comment 2 good enough? In that case the needinfo can be removed.
yep.
Flags: needinfo?(dirkjan)
Flags: qe-verify?
Flags: firefox-backlog+
The real fix here will be bug 1096247. However, the search engine page restyling is making this feel worse (and feel dumber) - so we'll disable it in bug 1096248 until we can come up with a proper fix.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1096247
You need to log in before you can comment on or make changes to this bug.