Scrolling on Firefox marketplace shows 'checkerboarding' immediately outside of the viewport

RESOLVED DUPLICATE of bug 1080205

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 1080205
4 years ago
4 years ago

People

(Reporter: cwiiis, Unassigned)

Tracking

({regression})

Trunk
All
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 fixed)

Details

(Reporter)

Description

4 years ago
If you scroll semi-quickly on Firefox Marketplace, you can see that it's checkerboarding immediately outside of the viewport. If you enable paint-flashing, you can see that it isn't redrawing this area, so I would suppose that it's a clipping issue. Possibly AsyncCompositionManager isn't transforming a layer's clip rect when it should?

Also cc'ing layout peeps in case any of the recent clipping changes may have caused this, but I don't expect so.
Considering this doesn't happen in any other apps I would guess this due to specific CSS in the marketplace app (and may even be a marketplace bug). The layer tree is pretty straightforward and the shadow clip rect looks fine to me.
Bug 1080205 is where we're actually tracking this issue, so marking this as a dependency.
Depends on: 1080205
See Also: bug 1080205

Updated

4 years ago
Duplicate of this bug: 1082870
(In reply to Chris Lord [:cwiiis] from comment #0)
> If you scroll semi-quickly on Firefox Marketplace

(FWIW, I see this bug even if I scroll the Marketplace *slowly* on my Flame. The just-scrolled-in area is almost always white, and it gets painted with the correct content a fraction of a second later.)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: regression
Bug 1080205 just landed on central so 2.2 builds from here on should not have this problem. Tagging qawanted to verify in the next nightly. Verification on 2.2 will help us uplift the fix to 2.1 as well.
Keywords: qawanted
So... this shows up on 2.1 as well?
blocking-b2g: --- → 2.1?
Yes, it does. (I see it there.)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #5)
> Bug 1080205 just landed on central so 2.2 builds from here on should not
> have this problem. Tagging qawanted to verify in the next nightly.
> Verification on 2.2 will help us uplift the fix to 2.1 as well.

This issue is verified fixed on latest tinderbox central engineering build. 'Checkerboarding' no longer occurs on Marketplace.

- Issue reproduces in the following build -
Device: Flame
BuildID: 20141105043145
Gaia: bc843fbf8973c8e124e5668bb2752f5d025fb488
Gecko: 72ae882fce1a
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

- Issue does NOT reproduce in the following build-
Device: Flame
BuildID: 20141105120748
Gaia: 7918024c737c4570cacd784f267e28737ae05dea
Gecko: b6cd2dd85b26
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
status-b2g-v2.2: affected → fixed
Flags: needinfo?(jmitchell)
Thanks for the confirmation! Closing as a dupe as that bug is already 2.1+ and this bug provides no additional value.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1080205
I'll mark this as a blocker so if the duplication is ever broken, it'll remain a blocker.
blocking-b2g: 2.1? → 2.1+
You need to log in before you can comment on or make changes to this bug.