need more bugzilla mail headers

RESOLVED DUPLICATE of bug 70710

Status

()

RESOLVED DUPLICATE of bug 70710
17 years ago
6 years ago

People

(Reporter: asa, Assigned: jacob)

Tracking

2.15
Other
Other

Details

(Reporter)

Description

17 years ago
We currently have X-Bugzilla-Reason with possible values of QAContact, Reporter,
Voter, AssignedTo, and CC. 

To make management of bugmail a lot better we need four more headers:

X-Bugzilla-Status
  Unconfirmed, New, Assigned, Reopened, Resolved, Verified, Closed

X-Bugzilla-whiteboard
  arbitrary
  
X-Bugzilla-Component
  all Components

X-Bugzilla-Severity
  Blocker, Critical, Major, Normal, Minor, Trivial, Enhancement
Yep. This is a modification to processmail; we need to get the additional fields
about each bug out of the DB, pass them to the DoOnePerson (or whatever it's
called) function, and make them substitutable in the headers. You'd then need to
document the new substitution keys in defparams.pl or whereever.

DoOnePerson already has about 10 parameters; we should consider using a hash
instead.

Gerv
bug 70710 even has a patch waiting for review already. :)

*** This bug has been marked as a duplicate of 70710 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.