Image borderlines disappears

RESOLVED WONTFIX

Status

()

Core
Layout
--
trivial
RESOLVED WONTFIX
16 years ago
16 years ago

People

(Reporter: Ido Beeri, Assigned: Marc Attinasi)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
The image borderline dissapears when the image already started to load and
there's another window over it. It's kinda annoying (at least for me).

Comment 1

16 years ago
Reporter - could you read the bug writing guidelines at:
http://www.mozilla.org/quality/bug-writing-guidelines.html
Without a build id or steps to reproduce, it is impossible for others to confirm
this bug. 

In future, consider using the bugzilla helper at:
http://www.mozilla.org/quality/help/bugzilla-helper.html
This will add many of the important details in for you.

Thanks for using mozilla and reporting bugs!
(Reporter)

Comment 2

16 years ago
ok. {Build ID: 2001101117}

2. Go to
http://www.renderosity.com/viewed.ez?galleryid=38319&Start=13&Artist=Bubba&ByArtist=Yes
3. wait until the image is started to load
4. minimize the window and restore it
5. the border lines are missing

Comment 3

16 years ago
What are "border lines"? Can you be more descriptive? I looked at the image
loading, minimized and restored the page and it looked the same. 

Comment 4

16 years ago
I'm also not seeing any unusual rendering ... but maybe I'm not looking for the
right thing.

Reporter, could you try making some before-and-after screenshots?  (PLEASE crop
them to only show the minimum amount necessary for us to get the point, place
them both into the same image (side-by-side), save it as a .jpg, and attach
using the "Create a new attachment" link above.  Make sure to specify the
correct mimetype.)
(Reporter)

Comment 5

16 years ago
Created attachment 56326 [details]
Before and After

Comment 6

16 years ago
over to layout. it looks like we create a space for the image and mark that off
and then we fill in the image and the marked off border goes away. I'm not sure
that's unintended behavior. on a slow connection I have time to minimize the
window and restore it before the whole image is painted and when I do that the
border is gone before the entire image has filled in. I guess this is what the
bug is reporting.
Assignee: asa → attinasi
Component: Browser-General → Layout
QA Contact: doronr → petersen
IMHO (and according to my spec) we shouldn't really ever be painting the borders
to the placeholder frames.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Target Milestone: --- → Future
(Assignee)

Comment 8

16 years ago
This is intentional. We draw a border around sized images while they are
loading. If the image bits have started coming in, we stop drawing that border,
hence the behavior that is being reported.

As Ian said, there are some who do not want the borders drawn at all, and some
(as evidenced by this bug) that want them all the time. IMO the current behavior
is reasonable so I'm closing this bug as WONTFIX.

BTW: we will probably want a pref to disable the border/icon showing during
load, as IE has... A bit tangential to this issue, but there it is anyway.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.