Status

defect
P3
normal
CLOSED WORKSFORME
20 years ago
9 years ago

People

(Reporter: greg, Assigned: edburns)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

20 years ago
whenever I launch apprunner, the title bar draws, then apprunner **** out with
the following error: The instruction at 0x503371b0 referenced memory at
0x608961c8.  The memory could not be "written"

After that, the rest of the browser window draws, but is blank.  This happened
with both M7 and M8.

I am running NT SP4.  My hardware is a Dell Precision Workstation 410 with dual
P-ii 400's the FireGL 1000 Pro and the U2W SCSI adapter.  I have another machine
that is single CPU and also NT SP4, and it runs great there.  That combined with
the asynchronous nature of the errors leads me to believe there may be a problem
in eithet NT's thread support or Mozilla's threading... but that's just a guess.

I pulled it into VC++ 5 and here's the stack where it crashed:

NPJAVA32! 503371b0()
OJI! 607f1ae7()
OJI! 607f1bc4()
JSDOM! 6066762f()
RAPTORWEB! 608b5d56()
NSAPPSHELL! 6079244e()
RAPTORWIDGET! 608c4c87()
RAPTORWIDGET! 608c4d00()
RAPTORWIDGET! 608c73f5()
RAPTORWIDGET! 608c4d7d()
USER32! 77e7131f()
USER32! 77e71a3d()
NTDLL! 77f7637b()
USER32! 77e7136c()
USER32! 77e72ba5()
USER32! 77e72b78()
RAPTORWIDGET! 608c4d9e()
USER32! 77e7131f()
USER32! 77e71a3d()
NTDLL! 77f7637b()
NSAPPSHELL! 6079191c()
APPRUNNER! 004017f5()
APPRUNNER! 00401fcb()
KERNEL32! 77f1ba3c()

I don't have the source installed, so I can't build a version with debug
symbols, sorry.

-Greg

Updated

20 years ago
Assignee: rpotts → beard
Component: Threading → OJI

Comment 1

20 years ago
It looks like this is an OJI/plugin issue...

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 2

20 years ago
If you have some older version of Sun's activator plugin, I'd suggest you remove
it. It had some old incompatible OJI code in it.

Updated

20 years ago
Assignee: beard → drapeau
Status: ASSIGNED → NEW

Updated

20 years ago
Assignee: drapeau → edburns
Assignee

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WORKSFORME
Assignee

Comment 3

20 years ago
Can't reproduce with latest mozilla and JDK1.3 on NT.
Reporter

Updated

20 years ago
Status: RESOLVED → CLOSED
Reporter

Comment 4

20 years ago
M9 and a fresh install of NT seem to have solved the problem.  (NT install was NT's fault *sigh*)  It could be that I installed JDK 1.2.2 instead of 1.2, which my old machine had. Different Activator version??? *shrug*

Updated

9 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.