[Homescreen] when tapping on Smart collection phone will reboot

RESOLVED DUPLICATE of bug 1083965

Status

Firefox OS
Gaia::Homescreen
RESOLVED DUPLICATE of bug 1083965
4 years ago
4 years ago

People

(Reporter: RJ, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [systemsfe], URL)

Attachments

(1 attachment)

431.72 KB, text/plain
Details
(Reporter)

Description

4 years ago
Created attachment 8498440 [details]
log cat

Description:
On a fresh flash in the 2.2 build when tapping the smart collection on the home screen, flame will reboot.

Repro Steps:
1) Update a Flame to 20141001040205
2) After a fresh flash to 2.2 tap a smart collection, any of the three can reproduce this 

   

Actual:
Screen goes black and flame reboots


Expected:
Launch smart collection

Environmental Variables:
Device: Flame Master
Build ID: 20141001040205
Gaia: 0e280591881d44b80f456bc27e12d9114c218868
Gecko: 14665b1de5ee
Version: 35.0a1 (Master)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Repro frequency: 1/4
See attached: logcat video clip: http://youtu.be/nCHnf1_d1JQ
(Reporter)

Comment 1

4 years ago
This issue DOES occur on Flame 2.2 (319mb)


When tapping on Smart collection phone will reboot

Flame 2.2 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140926040203
Gaia: a06714c555ca7068545f10b4437a16c14cd8e7f5
Gecko: 9e3d649b80a2
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Issue does NOT occur on  kitkat Flame 2.1(512MB) kitkat 2.0 (319mb) kitkat


Flame 2.1 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.1
Build ID: 20141001000202
Gaia: 86a3626055ed58b39525424126870dc0a503e79f
Gecko: c20912812877
Version: 34.0a2 (2.1)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0 KitKat Base (319mb)

Environmental Variables:
Device: Flame 2.0
Build ID: 20141001000205
Gaia: ddb7567c60b31dbcb27817f8c126bbba8dccb63b
Gecko: e3545ca967ae
Version: 32.0 (2.0)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
(Reporter)

Updated

4 years ago
Whiteboard: [systemsfe]
I haven't yet been able to reproduce this on Master - how are you flashing the device? And is it connected to wifi or data when it happens?
Flags: needinfo?(rmitchell)
(Reporter)

Comment 3

4 years ago
This was reproduced on today’s build Full flash, this can be reproduced with wifi or data on or off.This issue does have a rather low repro rate and we have only gotten it to reproduce on two devices today and one with more repros then the other.
Flags: needinfo?(rmitchell)
Not nominating this to block, this issue seems to occur on random devices.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Keywords: regression
Adding qawanted due to the severity of this issue to check and see if they can get a solid repro on this.
Keywords: steps-wanted
QA Whiteboard: [QAnalyst-Triage+]
I've been able to reproduce this bug in the latest Flame 2.2 KK set to 319mb.

STR:
1. Reboot Flame Device.
2. When the icons on the homescreen populate just tap on a collection icon.

Results: Phone reboots.

Repro Rate: 5/5

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141017073248
Gaia: 1daf2dadcd0d554c733661a4c0be1b82001e9da0
Gecko: 51892b39597a
Version: 36.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: steps-wanted
QA Contact: croesch
Additional Info

It seems this bug can only happen directly after a reset. I was not able to get it to happen if i had spent time on the phone then decided to tap on the collection icon later.
Confirmed on:

2.2 Tinderbox-Eng / V184 / 512 mem / shallow-flash

Device: Flame 2.2
Build ID: 20141017073248
Gaia: 1daf2dadcd0d554c733661a4c0be1b82001e9da0
Gecko: 51892b39597a
Version: 36.0a1 (2.2)
Firmware Version: v184
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


This might not be the most visible bug but I think the effects are worthy of nomming and finding a window on.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
There is a duplicate issue that came from Smoketest that has much more traction on it so I'm going to Future-Dupe (don't be sad RJ!)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: regressionwindow-wanted
Resolution: --- → DUPLICATE
Duplicate of bug: 1083965

Updated

4 years ago
QA Contact: croesch
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.