[FLDSET]Show/Hide of divs in a fieldset will disable form controls in them.

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
--
major
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: George Dittmeier, Assigned: rods (gone))

Tracking

({testcase})

Trunk
Future
x86
All
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010816
BuildID:    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010816

If I have several divs on a page that are all defined as "position: relative"
will exhibit layout problems if the div is hidden and then subsequently shown. 
This is especially problematic if the div contains form elements as those
elements will become unusable.

Reproducible: Always
Steps to Reproduce:
1.look at the two examples given.
2.
3.
(Reporter)

Comment 1

17 years ago
Also note that the <fieldset> border is leaving artifacts when divs are 
Hidden/Shown.
form controls.  This is more fieldset trouble, and likely a duplicate of one of
the other fieldset layout bugs.

George, you really want to try a build newer than 0.9.3.  I'm seeing one
painting issue with a background on those testcases, but all the form controls
remain usable.
Assignee: asa → rods
Component: Browser-General → HTML Form Controls
QA Contact: doronr → madhur
(Reporter)

Comment 3

17 years ago
I've been waiting for a newer build to be made available throught ximian Red-
Carpet.  There seems to be one now, so I'll check it out.  Trying to install 
new builds direct from Mozilla.org over the ximian packages was giving me lots 
of problems.  I can live with artifacts.  The controls were most important.  
(Reporter)

Comment 4

17 years ago
The new 0.9.5 build from ximian does NOT solve the problem.  A small tweak to 
the testcases (moved the fieldset below the buttons) shows that the issues 
still exist.  Check out the test cases. The form controls become unusable.
OK, I see the bug with the updated testcases.  :)

ccing jkeiser because he likes this stuff.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Show/Hide of divs can result in severe layout issues → Show/Hide of divs in a fieldset will disable form controls in them.

Comment 6

17 years ago
This isn't identical to bug 52975, but it's damn close ... rods made a note
there that it only happens in fieldsets, so they're at least related.
(Assignee)

Comment 7

17 years ago
futuring for now
Status: NEW → ASSIGNED
Summary: Show/Hide of divs in a fieldset will disable form controls in them. → [FLDSET]Show/Hide of divs in a fieldset will disable form controls in them.
Target Milestone: --- → Future

Updated

16 years ago
QA Contact: madhur → tpreston

Comment 8

16 years ago
Same with 2002050908/trunk/Win2K - changing OS: Linux -> All
Keywords: testcase
OS: Linux → All

Comment 9

16 years ago
*** Bug 143258 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
Created attachment 110225 [details]
div with display of none; when displayed, form elements are unresponsive.

This is a form with a fieldset with a div inside it containing some form
elements. When displayed, the form elements are unresponsive. (They are not
displayed as disabled though)

Wasn't working on 1.2.1 or Chimera latest, checked 1.3a just before uploading,
appears to be fixed.  Is this the same issue?
Confirmed; everything is working fine now in the original testcases as well as
this new one.  Time, and fixes to both fieldset and form controls, has healed
all things :)

Please reopen if you're still seeing this.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.