Some HTML pages are not displayed but prompted for downloading

VERIFIED DUPLICATE of bug 10627

Status

()

Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 10627
19 years ago
18 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: Gagan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
** Observed with 7/29/99 Win32 (Necko) build **

The above page is part of International performance test. This and some
other pages no longer load. Instead, you are prompoted for downloading
such pages.

The above server is using HTTP 1.1 and sends Connection:close before it
sends Content-Type header. See below:

---------------------------------------------
HTTP/1.1 200 OKCRLF
Date: Thu, 29 Jul 1999 18:54:09 GMTCRLF
Server: Apache/1.3.3 (Unix) mod_perl/1.16 rus/PL26.5CRLF
Connection: closeCRLF
Content-Type: text/html; charset=windows-1251CRLF
Expires: Thu, 01 Jan 1970 00:00:01 GMTCRLF
Last-Modified: Thu, 29 Jul 1999 18:54:09 GMTCRLF
Vary: accept-charset, user-agentCRLF
CRLF
<HTML>LF
<HEAD>LF
....
....
---------------------------------------------

4.7 and pre-necko 5.0 builds have no problem with this but the necko
build does.

The above output was obtained by using a view utility by erik which
outputs what the server sends in response to an http request.

Here's where you find the view utility:

http://warp/employees/erik/view/

Comment 1

19 years ago
probably a dup of bug 10627
(Reporter)

Comment 2

19 years ago
Paul it seems to be a duplicate. But I found something very
interesting at the other page mentioned in Bug 10627.

It apparently is not the Connection: close that is bothering us,
It is the Content Charset header we don't seem to be able to deal with.

Here's the view output:

------------------------------------------
HTTP/1.1 200 OKCRLF
Server: Lotus-Domino/ReleaseCRLF
Date: Thu, 29 Jul 1999 19:09:55 GMTCRLF
Content-Base: http://www.nvidia.com/Home.nsfCRLF
Content-Type: text/html; charset=US-ASCIICRLF
Content-Length: 20914CRLF
Last-Modified: Tue, 27 Jul 1999 09:01:03 GMTCRLF
Expires: Tue, 27 Jul 1999 09:01:03 GMTCRLF
CRLF
<HTML>LF
<!-- Lotus-Domino (Release 5.0 - March 30, 1999 on Windows NT/Intel) -->LF
<HEAD>LF
------------------------------------------

Note that this page doesn't send "Connection:close" but does send
the HTTP Charset header in the Content-type line.

This impacts internaitonal testing where it involves HTTP charset
headers.

Comment 3

19 years ago
My guess is that the code parsing the content-type header is not parsing for
parameter and is trying to match the entire string
"text/html; charset=US-ASCII" to the known content types when it should be just
trying to matching "text/html".  But the charset parameter should be maintained
(see bug #8443).

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 4

19 years ago
*** This bug has been marked as a duplicate of 10627 ***
(Reporter)

Comment 5

19 years ago
The other bug now has some info about the HTTP charset header
and so it's OK to verify this bug as a duplicate.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
okay, done

Comment 7

18 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.