downsizes fonts after 4th line or so

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Jim Michaels, Unassigned)

Tracking

31 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

I typed in:
there is no ./configure script included with 2.9.1 as the INSTALL.libxml2 file instructs.
I am not a total *nix geek. I know my way around the commandline and I can probably do enough research to do development, but I have no idea what to do with
acinclude.m4
autogen.sh


Actual results:

after a while, lines come out with really tiny font and (mixed) is displayed. I didn't touch the font size button. my fingers may have whacked something accidentally, my keyboard skills have gone downhill after turning 40. but I doubt that this is the problem, since it's been happening consistently.

right now, I have an 7-8pt font for top of the message, about 5pt for the last line of the message, and about 12-14pt for the signature. not sure why this is.

https://support.mozilla.org/en-US/products/thunderbird/learn-basics-get-started
lists no hotkeys, which there probably are some I don't know about, and I need to know what they are so I can avoid them or use them to fix a problem.


Expected results:

- make a web page which lists the hotkeys
- font size should be consistent unless I change the font of a selection or hit the font size button and start typing.

Updated

4 years ago
Component: Untriaged → Message Compose Window
OS: Windows 7 → Linux
Whiteboard: [dupeme?]
(Reporter)

Comment 1

4 years ago
it does this while I am typing. all of a sudden, I am in a different font size. it's a consistently repeatable bug, and annoying.


I can't set the font size or do any fancy editing like I can do with normal email compose for HTML signatures.
Hi Jim,

(In reply to Jim Michaels from comment #0)

> https://support.mozilla.org/en-US/products/thunderbird/learn-basics-get-
> started
> lists no hotkeys, which there probably are some I don't know about, and I
> need to know what they are so I can avoid them or use them to fix a problem.
> Expected results:
> 
> - make a web page which lists the hotkeys

Good news for you, we DO have a list of shortcuts, once painstakingly compiled by myself: https://support.mozilla.org/en-US/kb/keyboard-shortcuts

I acknowledge that this part of the documentation is not easy to find, should probably have its own top-level entry ("help topic") on our support start page. You could file a bug about that if there isn't one yet.

> - font size should be consistent unless I change the font of a selection or
> hit the font size button and start typing.

This works for me, and for a blank composition, there's technically no way that the font size could change without prior action from you. We do have some bugs where typing in HTML-formatted text like quotes etc. can go wrong, but in your case, it's much more likely that you have hit one of the "font size" keyboard shortcuts accidentally.

https://support.mozilla.org/en-US/kb/keyboard-shortcuts#w_writing-messages

Ctrl + <  Smaller font size
Ctrl + >  Larger font size

On some keyboard layouts, some of these shortcuts require using Ctrl+Shift+...

As a courtesy for such keyboard layouts, so that users can omit the Shift key for these shortcuts, we also have these:
Ctrl + ,  Smaller font size
Ctrl + .  Larger font size

Unfortunately, perhaps due to a human error where someone introduced "tb31" as a tag for TB 3.1, which now conflicts with the current tag of "tb31" for TB 31, that particular part of the keyboard shortcuts documentation is currently in disarray (you're welcome to file a bug about that and CC me if none exists yet).

Hope that helps.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Whiteboard: [dupeme?]
You need to log in before you can comment on or make changes to this bug.