Last Comment Bug 107651 - Handle multiple file drops on mozilla (gtk build) using the text/uri-list target
: Handle multiple file drops on mozilla (gtk build) using the text/uri-list target
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Christopher Blizzard (:blizzard)
: John Morrison
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-30 15:33 PST by James Henstridge
Modified: 2001-11-06 15:35 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Convert text/uri-list drops to a multi-file text/x-moz-url drop (6.94 KB, patch)
2001-10-30 15:36 PST, James Henstridge
markh: review+
Details | Diff | Splinter Review
Simple XUL example to test text/uri-list drops (1.68 KB, text/plain)
2001-10-30 15:40 PST, James Henstridge
no flags Details
second attempt, with text/uri-list parsing code split into helper functions (7.51 KB, patch)
2001-10-31 15:39 PST, James Henstridge
blizzard: superreview+
Details | Diff | Splinter Review

Description James Henstridge 2001-10-30 15:33:42 PST
At the moment, it is not possible to drop multiple files from a file manager
such as nautilus on mozilla.  The de-facto standard for multi-file drops is to
use the text/uri-list target.  It is not possible to handle these drops from the
javascript layer because the data format for text/uri-list drops is ascii,
rather than 2 byte unicode, so the data gets misinterpreted.

Attached is a patch that adds support for text/uri-list, by treating it like a
drop of multiple text/x-moz-url flavour items.  This should make text/uri-list
drops usable to javascript DND Observers, while not needing special knowledge of
the conventions used on X11 dnd.
Comment 1 James Henstridge 2001-10-30 15:36:35 PST
Created attachment 55829 [details] [diff] [review]
Convert text/uri-list drops to a multi-file text/x-moz-url drop
Comment 2 James Henstridge 2001-10-30 15:40:01 PST
Created attachment 55832 [details]
Simple XUL example to test text/uri-list drops
Comment 3 Mark Hammond [:markh] 2001-10-30 16:13:31 PST
Comment on attachment 55829 [details] [diff] [review]
Convert text/uri-list drops to a multi-file text/x-moz-url drop

r=markh
Comment 4 Brendan Eich [:brendan] 2001-10-30 16:19:58 PST
blizzard, can you sr= and maybe check this in?

/be
Comment 5 Christopher Blizzard (:blizzard) 2001-10-31 10:00:07 PST
The code looks fine.  Can you pull the two parser loops into seperate functions
to make it more readable and maintainable, please?
Comment 6 James Henstridge 2001-10-31 15:39:50 PST
Created attachment 56000 [details] [diff] [review]
second attempt, with text/uri-list parsing code split into helper functions
Comment 7 Christopher Blizzard (:blizzard) 2001-11-06 15:21:55 PST
Comment on attachment 56000 [details] [diff] [review]
second attempt, with text/uri-list parsing code split into helper functions

sr=blizzard
Comment 8 Christopher Blizzard (:blizzard) 2001-11-06 15:35:32 PST
Checked in on behalf of James.

Note You need to log in before you can comment on or make changes to this bug.