Closed Bug 1076709 Opened 5 years ago Closed 5 years ago

"Beta" Tag to be added to the panel

Categories

(Hello (Loop) :: Client, defect)

defect
Not set
Points:
3

Tracking

(firefox34 verified, firefox35 verified)

VERIFIED FIXED
mozilla35
Iteration:
35.3
Tracking Status
firefox34 --- verified
firefox35 --- verified

People

(Reporter: RT, Assigned: jaws)

References

Details

(Whiteboard: [loop-uplift])

Attachments

(5 files, 1 obsolete file)

Attached image Beta tag.png
Add a beta tag to the panel per attached mock-up.
Note that we can't use CSS rotated text here due to bug 534064.
Michael, can you provide the "Beta tag" asset for this?
Flags: needinfo?(mmaslaney)
RT, Shell -- FYI.  Jared is ready to start working on this now.  We will also move the Loop button to Customize in Fx34 and replace Loop (or blank) with Hello as the product name.   Can you help me make sure that we have all the bugs for Jared and link them to this bug?  

I believe there are 2 (one for moving the Loop button to Customize and a second for making the name change).
Flags: needinfo?(sescalante)
Flags: needinfo?(rtestard)
Flags: qe-verify?
Flags: firefox-backlog+
Depends on: 1074458, 1070753, 1013989
Flags: needinfo?(sescalante)
Hi Darrin - we just need the SVG for this one to implement.  Jared is ready to go for it.
Flags: needinfo?(dhenein)
Flags: qe-verify? → qe-verify+
No longer depends on: 1070753, 1074458
Depends on: 1074458
No longer depends on: 1074458
Depends on: 1077143
Clearing NI as ShHell created the bugs.
Flags: needinfo?(rtestard)
Here is the beta tag asset.
Flags: needinfo?(dhenein)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Iteration: --- → 35.3
Points: --- → 3
Attached patch Patch (obsolete) — Splinter Review
Attachment #8501549 - Flags: review?(mdeboer)
Comment on attachment 8501549 [details] [diff] [review]
Patch

Review of attachment 8501549 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/loop/content/shared/css/common.css
@@ -232,5 @@
>  
>  /* Alerts/Notifications */
>  .notificationContainer {
>    border-bottom: 2px solid #E9E9E9;
> -  margin-bottom: 1em;

I guess you need this to make the ribbon stick to the top when notifications are visible? If not, why is this necessary and what's the effect on the notifications layout?

::: browser/components/loop/content/shared/css/panel.css
@@ +100,5 @@
> +}
> +
> +.tab-view + .tab .content-area header {
> +  /* The header shouldn't be indented if the tabs are present. */
> +  -moz-padding-start: 0;

The tabs make the ribbon go away, so this doesn't seem to fix something... I'll attach a screenshot shortly.

::: browser/components/loop/content/shared/img/beta-ribbon.svg
@@ +3,5 @@
> +   - License, v. 2.0. If a copy of the MPL was not distributed with this
> +   - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->
> +<svg xmlns="http://www.w3.org/2000/svg"
> +     viewBox="0 0 100 100"
> +     xmlns:xlink="http://www.w3.org/1999/xlink"

you don't need to xlink if it's just one path.
Attachment #8501549 - Flags: review?(mdeboer) → feedback+
Darrin, are we OK with this always being on the left side even in RTL locales? We can't do a horizontal flip on it for RTL due to the embedded text in the SVG (though offline communication I have been told that we are not going to localize this text, and are not concerned about screen readers picking it up).
Flags: needinfo?(dhenein)
I'm ok with this always appearing on the left. It's beta, right? ;)
Flags: needinfo?(dhenein)
Attached patch Patch v2Splinter Review
Yeah the margin change is needed to get the beta tag to be displayed against the notifcations. I'll attach screenshots to show.

I couldn't reproduce the issue with the beta tag being behind the tab view on OSX. It looks good to me on there with this patch.
Attachment #8501549 - Attachment is obsolete: true
Attachment #8502636 - Flags: review?(mdeboer)
Attachment #8502636 - Flags: review?(mdeboer) → review+
https://hg.mozilla.org/integration/fx-team/rev/f09199bad120
Flags: in-testsuite-
Whiteboard: [loop-uplift] → [loop-uplift][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/f09199bad120
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [loop-uplift][fixed-in-fx-team] → [loop-uplift]
Paul, this should be in the next Nightly. Can you please test it on Monday? I will be out due to a Canadian holiday.
Flags: needinfo?(paul.silaghi)
QA Contact: anthony.s.hughes → paul.silaghi
Target Milestone: mozilla34 → mozilla35
Comment on attachment 8502636 [details] [diff] [review]
Patch v2

Approval Request Comment
We need a "Beta" graphic for Loop/Hello to indicate the current state of the feature.  The graphic will be in all versions of the browser (Nightly through Fx34) until we're ready to remove it. For Fx34, it should never be removed.  We do plan to remove the graphic part-way through the Fx35 cycle.

There are no strings.
Attachment #8502636 - Flags: approval-mozilla-aurora?
Approval Request Comment
[Feature/regressing bug #]: Displaying "Beta" tag for the Loop/Hello feature
[User impact if declined]:  Users will not know that this is a "Beta" release for the Loop/Hello features
[Describe test coverage new/current, TBPL]: Visible in every build
[Risks and why]: This is low risk to update.
[String/UUID change made/needed]:None
Verified fixed FF 35.0a1 (2014-10-13) Win 7, Ubuntu 13.04, OS X 10.9.5
Status: RESOLVED → VERIFIED
Flags: needinfo?(paul.silaghi)
Comment on attachment 8502636 [details] [diff] [review]
Patch v2

Convert aurora? to beta?
Attachment #8502636 - Flags: approval-mozilla-aurora? → approval-mozilla-beta?
Comment on attachment 8502636 [details] [diff] [review]
Patch v2

Beta+

jesup - Please land ASAP so that this can get into beta1.
Attachment #8502636 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: needinfo?(rjesup)
I just noticed that the Beta tag is also showing up in Nightly and Aurora builds. I question whether we want a Beta tag to show up in those channels.
Yeah, I also mentioned that as being weird.
We talked about this in our meeting where we decided to implement this bug.  We thought we should keep the Beta tag until Rooms is complete and has enough polish to remove it.  In the meantime it's a reminder to folks that we know we're not done (not that there are that many folks looking at Nightly and Aurora).   As a bonus, it simplifies the code path.  We'll remove the tag when we've reached critical mass.
Verified fixed in the latest Beta.
Flags: in-moztrap-
You need to log in before you can comment on or make changes to this bug.