Closed Bug 1076739 Opened 5 years ago Closed 5 years ago

[woodduck] HFP has no sound when BT device support HFP1.6

Categories

(Firefox OS Graveyard :: GonkIntegration, defect, P1, critical)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.0M+, b2g-v1.4 unaffected, b2g-v2.0 unaffected, b2g-v2.0M verified, b2g-v2.1 unaffected, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S6 (10oct)
blocking-b2g 2.0M+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected
b2g-v2.0M --- verified
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified

People

(Reporter: seinlin, Assigned: seinlin)

References

Details

Attachments

(1 file)

HFP has no sound when BT device support HFP1.6
There is a permission error in log.
--
09-22 18:02:40.548   175   175 D AudioSystem: +setParameters(): SET_DAIBT_MODE=1
09-22 18:02:40.553   149  1139 D AudioFlinger: setParameters(): io 0, keyvalue SET_DAIBT_MODE=1, calling pid 175
09-22 18:02:40.553   164   348 E gonkperm: android.permission.MODIFY_AUDIO_SETTINGS for pid=175,uid=1002 denied: not an app
09-22 18:02:40.553   149  1139 W ServiceManager: Permission failure: android.permission.MODIFY_AUDIO_SETTINGS from uid=1002 pid=175
09-22 18:02:40.553   149  1139 E         : Request requires android.permission.MODIFY_AUDIO_SETTINGS
09-22 18:02:40.553   175   175 D AudioSystem: -setParameters(): SET_DAIBT_MODE=1
blocking-b2g: --- → 2.0M?
Whiteboard: [2.0M_only]
Michael, Could you review this patch?

In woodduck there is a bt native process (such as pid=175 in comment 1). 
By default bt call use 8khz sampling rate (NB). 
When hfp profile 1.6 is used bt task need will use setparameters to change the sampling rate to 16 khz (wb). 
If bt task do not grant the permission there will be an error.
Attachment #8498755 - Flags: review?(mwu)
So this is something different from AOSP. They have their own way to handle Wideband speech?
Blocks: Woodduck
blocking-b2g: 2.0M? → 2.0M+
Whiteboard: [2.0M_only] → [partner-blocker][2.0M_only]
(In reply to Shawn Huang [:shawnjohnjr] from comment #3)
> So this is something different from AOSP. They have their own way to handle
> Wideband speech?

Yes, they have a native process for bt.
Thomas, is this something that the bluetooth daemon will need to be able to do? Seems like a generally valid thing to do.
Flags: needinfo?(tzimmermann)
So far we only know that woodduck is using complete proprietary close source bluetooth stack, the stack has different architecture but supports the same Android Bluetooth HAL interface, and it supports wide band speech which needs to call audio library directly.
(In reply to Michael Wu [:mwu] from comment #5)
> Thomas, is this something that the bluetooth daemon will need to be able to
> do? Seems like a generally valid thing to do.

Yeah, looks like this will need to be done by the daemon. Thanks for letting me know.
Flags: needinfo?(tzimmermann)
Hi Kai-Zhen,
I am cleaning Woodduck bug that assign to no one.
Since you create the patch in comment 2, could you also kindly take it as owner?
Thanks!
Flags: needinfo?(kli)
Assignee: nobody → kli
Flags: needinfo?(kli)
Comment on attachment 8498755 [details] [diff] [review]
bug-1076739-fix.patch

Review of attachment 8498755 [details] [diff] [review]:
-----------------------------------------------------------------

Ok. This looks good to me, but let's open a new public bug for this and land it on m-c first. Then uplift to 2.0m. Request review from :tdz.
Attachment #8498755 - Flags: review?(mwu)
Not a Confidential Bug.
Group: woodduck-confidential
Comment on attachment 8498755 [details] [diff] [review]
bug-1076739-fix.patch

Thomas, 

Could you review this patch? 
If you also think this need to be landed on m-c, can you help the update tracking flag status-b2g-v2.2: to affected? 

Thanks!
Attachment #8498755 - Flags: review?(tzimmermann)
Comment on attachment 8498755 [details] [diff] [review]
bug-1076739-fix.patch

Review of attachment 8498755 [details] [diff] [review]:
-----------------------------------------------------------------

Hi Kai-Zhen,

Looks good. Please also land the patch on m-c.
Attachment #8498755 - Flags: review?(tzimmermann) → review+
Or maybe let's check the status of Woodduck in m-c. Shawn, will the Woodduck patches have to be applied to m-c as well?
Flags: needinfo?(shuang)
AFAIK, the current rule is that if the bug is general and can be reproduced on flame, we should apply to m-c. In general, we shall minimize the difference. I guess current bluedroid (KK based) does not handle wide band speech (HD voice), so the bug does not happen on m-c.
Flags: needinfo?(shuang)
Per comment 12.
Whiteboard: [partner-blocker][2.0M_only] → [partner-blocker]
https://hg.mozilla.org/mozilla-central/rev/62babb0d3ae2
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S6 (10oct)
Whiteboard: [partner-blocker]
Duplicate of this bug: 1059037
This issue has been verified successfully on Flame 2.2 and woodduck 2.0, and we can listen the voice(Call, Music, Video) from BT headset(PLantronix M25), and all voice is clearly.
Reproducing rate: 0/5

Step:
1.Device connect to Plantronics M25 use BT.
2.Call a number or receive a call.
**When have call coming, the BT headset is normally, and when the call is connecting, tap the number in dialer, the voice can be listened from BT headset.
3.Launch Music, play a song use BT headset.
**The voice from BT headset is clearly.
4.Launch Browser, go to "www.youtube.com", select a video to play.
**The voice from BT headset is clearly.

Woodduck version:
Gaia-Rev        87b23fa81c3b59f2ba24b84f7d686f4160d4e7cb
Gecko-Rev       d049d4ef127844121c9cf14d2e8ca91fd9045fcb
Build-ID        20141125050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1416863158
FW-Date         Tue Nov 25 05:06:35 CST 2014

Flame 2.2 version:
Gaia-Rev        aad40f6d6eb8f626c6a20db55b9f00d2e832f113
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/be4ba3d5ca9a
Build-ID        20141124100136
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141124.132512
FW-Date         Mon Nov 24 13:25:25 EST 2014
Bootloader      L1TC00011880
Status: RESOLVED → VERIFIED
Blocks: Woodduck_P2
Priority: -- → P1
No longer blocks: Woodduck_P2
You need to log in before you can comment on or make changes to this bug.