Closed Bug 1076796 Opened 7 years ago Closed 6 years ago

Debugging devtools add-ons is hard

Categories

(DevTools :: Debugger, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: canuckistani, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [status:backlog])

I shoulder-surfed James trying to debug a bootstrapped add-on using the add-on debugger, and it's currently not fun trying to get an interactive console hooked to a script running in the extensions tool pane. This is also a problem for extensions using our new apis.
Whiteboard: [status:backlog]
How far along is the work for iframe switching? Does seem like once that's integrated this would be easy.
(In reply to James Long (:jlongster) from comment #1)
> How far along is the work for iframe switching? Does seem like once that's
> integrated this would be easy.

I don't know. Do we have a bug open for that?
(In reply to Eddy Bruel [:ejpbruel] from comment #2)

> I don't know. Do we have a bug open for that?

I couldn't find it, but I thought I heard someone was working on it.
(In reply to Eddy Bruel [:ejpbruel] from comment #2)
> (In reply to James Long (:jlongster) from comment #1)
> > How far along is the work for iframe switching? Does seem like once that's
> > integrated this would be easy.
> 
> I don't know. Do we have a bug open for that?

I believe you are looking for bug 1059308.
James, what's your experience here now that we have iframe switching in BT?
Flags: needinfo?(jlong)
I don't have the same environment set up as I did before to really test this, but I'd be willing to bet that that iframe window does fix it. Seems like I could switch context into my addon's panel.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(jlong)
Resolution: --- → WORKSFORME
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.