Closed Bug 1076941 Opened 5 years ago Closed 5 years ago

Re-enable the toolkit webapps tests on OSX 10.8 when they meet visibility requirements

Categories

(Core Graveyard :: DOM: Apps, defect)

x86_64
macOS
defect
Not set

Tracking

(firefox34 fixed, firefox35 fixed)

RESOLVED FIXED
mozilla35
Tracking Status
firefox34 --- fixed
firefox35 --- fixed

People

(Reporter: RyanVM, Assigned: spohl)

References

Details

Attachments

(1 file, 3 obsolete files)

To start, sorry for the rather abrupt disabling here :(

After last week's NSS chemspill, we noticed frequent timeouts of the toolkit webapps tests. At the time, they appeared to be limited to Gecko33 and under. Given the unlikeliness of them getting attention on older branches, I skipped the tests on those branches with Fabrice's blessing.

Fast-forward to today where something made them go crazy on inbound as well :(
https://treeherder.mozilla.org/ui/logviewer.html#?job_id=2712798&repo=mozilla-inbound

The log above is a very typical instance of this failure. It happens only on OSX and affects both opt and debug. Due to the failure rate, I need to disable them right away. Sorry for the lack of notice :(
Assignee: ryanvm → nobody
Looks like the error is: "webapprt[1363:303] got exception: Cannot locate binary for this App", I wonder if bug 1075492 fixed this problem too.
(In reply to Marco Castelluccio [:marco] from comment #2)
> Looks like the error is: "webapprt[1363:303] got exception: Cannot locate
> binary for this App", I wonder if bug 1075492 fixed this problem too.

No. These were happening on inbound right up to the push prior to the disabling landing on it.
Are you able to tell when these tests started going crazy?
Oh, I bet bug 1075492 is actually the culprit here, sorry. Patch coming up.
Assignee: nobody → spohl.mozilla.bugs
Status: NEW → ASSIGNED
Attached patch Patch (obsolete) — Splinter Review
I'm not quite sure how to test this, but this should fix the reported failures.
Attachment #8499101 - Flags: review?(myk)
A Try run with comment 1 reverted and 5-10 retriggers should make it pretty clear if your patch works or not.
Comment on attachment 8499101 [details] [diff] [review]
Patch

RyanVM said that we see strange errors on other branches as well, where my patch from bug 1075492 hasn't (shouldn't?) have landed yet. I'll take this opportunity to improve this code.
Attachment #8499101 - Flags: review?(myk)
Attached patch Patch (obsolete) — Splinter Review
We're now checking whether the path to Contents/MacOS/webapprt exists on disk rather than asking the OS to provide us with a path to the webapprt directory. The API that was previously used (NSBundle pathForAuxiliaryExecutable) is intended to retrieve helpers and applications under Contents/MacOS in the app bundle. The webapprt folder obviously isn't a helper or an application bundle. The API just happened to return the proper path because the OS treats any folder under Contents/MacOS as an application bundle.

Reverted comment 1 and submitted to try:
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=bafa75eaaeb2
Attachment #8499101 - Attachment is obsolete: true
Attachment #8499135 - Flags: review?(myk)
I just triggered a few more m-oth runs to confirm the fix. All completed runs have been green so far:
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=bafa75eaaeb2
FWIW, they're still disabled on 10.6 ;)
Hah, that's awesome! Way to get my hopes up. :-)
I triggered a few more 10.6 m-oth runs. Since 10.8 is lagging and the previous push had 10.8 enabled I am not going to trigger additional 10.8 jobs on my push.
It doesn't seem to have fixed the 10.6 errors that started before v2 signing landed and is covered by bug 993690. Let's go with the 10.8 fix that was caused by the v2 signing and let bug 993690 handle the 10.6 failures.
Attachment #8499135 - Flags: review?(myk) → review+
Attached patch Reenable tests (obsolete) — Splinter Review
Since this is a straight backout, I'm not sure it has to be reviewed again. Ryan, should I land this at the same time as the patch in this bug? Or are there other reasons why the tests should remain disabled? Thanks!
Attachment #8499500 - Flags: review?(ryanvm)
Comment on attachment 8499500 [details] [diff] [review]
Reenable tests

Just include it with the patch.
Attachment #8499500 - Attachment is obsolete: true
Attachment #8499500 - Flags: review?(ryanvm)
Attached patch PatchSplinter Review
Folded backout into this patch. Carrying over r+.

Waiting for inbound to reopen. Landed on oak:
https://hg.mozilla.org/projects/oak/rev/ebf3623173cf
Attachment #8499135 - Attachment is obsolete: true
Attachment #8499512 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/2f7bdbc8beb2
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Duplicate of this bug: 1077657
Landed on aurora in the Mac V2 signing combined patch in bug 1047584
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.