If the revision associated with a job is unknown to treeherder, ingest that push from json-pushes

RESOLVED DUPLICATE of bug 1077136

Status

Tree Management
Treeherder
P1
normal
RESOLVED DUPLICATE of bug 1077136
4 years ago
4 years ago

People

(Reporter: emorley, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
Currently, if we ingest a job from builds-{running,pending,4hr} and the revision SHA associated with the push is not recognised, we throw away the job.

If instead, we manually ingested that push from json-pushes, prior to then ingesting the job as normal, we would prevent the vast majority of missing push issues (other than from DONTBUILD pushes).

This would reduce the impact of missing pushes, prior to bug 1076752 being fixed.

IMO this is a preferred approach over bug 1076812, so we'll likely wontfix bug 1076812.
(Reporter)

Comment 1

4 years ago
We should also probably log the instances where we hit the fall-back here, so we can track when we are not correctly ingesting the pushlog.
(Reporter)

Comment 2

4 years ago
Forward duping to bug 1077136, since that has a PR open now.
No longer blocks: 1059400, 1076750
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1077136
You need to log in before you can comment on or make changes to this bug.