mozilla crashes if ftp URL contains invalid character

VERIFIED DUPLICATE of bug 107355

Status

()

VERIFIED DUPLICATE of bug 107355
17 years ago
17 years ago

People

(Reporter: bulbul, Assigned: bbaetz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Mozilla will usually crash if an ftp URL entered in the URL field contains an
invalid character, such as "<" or "*", added to the end, such as:

   ftp://ftp.redhat.com<
   ftp://ftp.redhat.com*

One time out of about eight in which i tried this, the extraneous character was
converted to a percent sign and number, as it does when the URL is HTTP
protocol, and the browser did not crash.

Using Linux trunk build 2001-10-28-06. Will attach talkback incident.
(Reporter)

Comment 1

17 years ago
Created attachment 55870 [details]
talkback incident
(Assignee)

Comment 2

17 years ago
This is possibly caused by bug 107355, which was caused over the weekend, and
fixed yesterday.

Can you try with a more recent build?

To look up a talback number, I need the incident id. There should be a talkback
program, and if you run that it should have the number (starting with TB). If it
still crashes with a build from today or later, then please mention that number.

Comment 3

17 years ago
on build 2001103012, no crash.

I see an alert box, and the source <html><body></body></html> is displayed in
the browser.
(Reporter)

Comment 4

17 years ago
Okay, i can't get it to crash in 2001-10-30-12.

(So as not to litter this bug, i will ask you a question regarding your comment
about talkbacks in an e-mail.)
(Reporter)

Comment 5

17 years ago
> on build 2001103012, no crash. I see an alert box, and the source 
> <html><body></body></html> is displayed in the browser.

Ditto for me. Should a new bug be opened (if it isn't already), or should the
summary line of this bug be changed to indicate this behavior?
    
(Assignee)

Comment 6

17 years ago
Marking a dupe, then, I guess.

*** This bug has been marked as a duplicate of 107355 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

17 years ago
The behavior of displaying "<html><body></body></html>" is covered by bug 102737.

Comment 8

17 years ago
VERIFIED: doesn't crash anymore, rc1, win98
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.