Ensure that stage has the same data as production for non-buildbot repos/jobs too

RESOLVED DUPLICATE of bug 1169320

Status

P5
normal
RESOLVED DUPLICATE of bug 1169320
4 years ago
3 years ago

People

(Reporter: emorley, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
Currently for buildbot jobs, dev+stage+prod all ingest pushlog and builds-{pending,running,4hr}, which means that it's possible to effectively test ETL/UI changes on the same data that production has.

However for non-buildbot jobs, the data isn't polled, but instead submitted by treeherder-client. Projects typically start by submitting only to stage (which is very much desirable to avoid issues with prod), and then when ready, switch to submitting to only production. This means we are then missing the job data for them on stage.

We should come up with a way to ensure they continue to submit to stage (eg by modifying treeherder-client to POST to both) or else come up with a way to mirror from prod to stage on the service side.
(Reporter)

Updated

4 years ago
Blocks: 1080757
No longer blocks: 1072681
(Reporter)

Updated

4 years ago
No longer blocks: 1080757
(Reporter)

Updated

4 years ago
Component: Treeherder → Treeherder: Infrastructure
QA Contact: laura
(Reporter)

Updated

4 years ago
Priority: P3 → P4
(Reporter)

Updated

4 years ago
Priority: P4 → P5
(Reporter)

Updated

3 years ago
See Also: → bug 1169320

Comment 1

3 years ago
Hi Ed, what is the status of this?
I might misremember but I heard that the client already posts to both places; is this true?
If so, would that be sufficient?

I'm just trying to understand issues related to TC. Thanks!
(Reporter)

Comment 2

3 years ago
(In reply to Armen Zambrano G. (:armenzg - Toronto) from comment #1)
> Hi Ed, what is the status of this?

For anyone else following this bug - Armen joined today's Treeherder meeting - and we briefly discussed a few ways of doing this. We're going to have more of a discussion at Whistler about a few different approaches.
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
See Also: bug 1169320
Duplicate of bug: 1169320
You need to log in before you can comment on or make changes to this bug.