If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[2.1][l10n][Settings] Portuguese: The string 'Birthday' in Add Contact is truncated.

VERIFIED FIXED

Status

Mozilla Localizations
pt-PT / Portuguese
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Petes, Assigned: cesperanc)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected)

Details

(Whiteboard: LocRun2.1-1)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8499034 [details]
2014-10-02-14-00-28.png

Description:
The string 'Birthday' is truncated under Settings > Contacts.

Repro Steps:
1) Update a Flame to BuildID: 20141002000202.
2) Set the device language as Portuguese(Europeu).
3) Navigate to Settings > Contacts
4) Tap Add contact.


Actual:
The 'Birthday' string is truncated in Portuguese.

Expected:
The 'Birthday' string is NOT truncated in Portuguese.


Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141002000202
Gaia: 94dcc25f2e34a4900ea58310c26be52bcb089161
Gecko: baaa0c3ab8fd
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro Frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/12553/
See attached screenshot
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
(Reporter)

Comment 1

3 years ago
This issue does not reproduce on the Flame 2.0 KitKat Base (319mb)(Full Flash) because the language was not available.

Environmental Variables:
Device: Flame 2.0
BuildID: 20141003000204
Gaia: fa797854bfe708129ed54a158ad4336df1015c39
Gecko: 9b7fd1f78a15
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Leaving to localizer to see what to do here. I see in French the localizer decided to put only the word "Birthday" so that it's less truncated, and since there is still "Date" on the right to choose from. So that way meaning is not lost
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
(Assignee)

Comment 3

3 years ago
Created attachment 8501955 [details]
Screenshot with the proposed fix
Assignee: joao.neves → cesperanc
Status: NEW → ASSIGNED
(Assignee)

Comment 4

3 years ago
I've made the necessary changes to correct the issue on http://mozilla.locamotion.org/pt/firefoxos/ (see attachment). When the changes are pushed to gaia-l10n the issue should be resolved.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

3 years ago
Issue resolved
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.