Closed Bug 1077022 Opened 5 years ago Closed 5 years ago

[Keyboard] European Portuguese (pt-PT) based keyboard is missing from gaia repository

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S6 (10oct)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: smiko, Assigned: cesperanc)

References

Details

(Whiteboard: [LocRun2.1-1])

Attachments

(2 files)

Description:
When users enable the Portuguese based keyboard they will observe the keyboard lacks autocorrection.
   
Setup:
-Confirm Autocorrection is enabled
-Setup custom gaia build:
CD into gaia folder
 + git pull
 + git checkout v2.1
 + git pull
 + MOZILLA_OFFICIAL=1 GAIA_KEYBOARD_LAYOUTS=en,pt-PT make reset-gaia

Repro Steps:
1) Update a Flame device to BuildID: 20141001000202
2) Enable the Macedonian based keyboard and enter Rocketbar
3) Start typing on keyboard and observe lack of autocorrection 
  
Actual:
Macedonian based keyboard lacks autocorrection
  
Expected: 
Autocorrection is present
  
Flame 2.1 KitKat Base (512mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141002000202
Gaia: 94dcc25f2e34a4900ea58310c26be52bcb089161
Gecko: baaa0c3ab8fd
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency: 3/3
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Summary: [Keyboard] European Portuguese keyboard is missing from gaia folder → [Keyboard] European Portuguese (pt-PT) based keyboard is missing from gaia repository
Whiteboard: [LocRun2.1-1]
Assignee: joao.neves → nobody
Component: pt-PT / Portuguese → Gaia::Keyboard
Product: Mozilla Localizations → Firefox OS
QA Contact: joao.neves
Please ignore original description. 
Updated description:

The European Portuguese (pt-PT) keyboard is not found in the gaia repository
   
Setup:
-Confirm Autocorrection is enabled
-Setup custom gaia build:
CD into gaia folder
 + git pull
 + git checkout v2.1
 + git pull
 + MOZILLA_OFFICIAL=1 GAIA_KEYBOARD_LAYOUTS=en,pt-PT make reset-gaia

Repro Steps:
1) Update a Flame device to BuildID: 20141002000202
2) Open Settings >  Keyboards > Select Keyboards

Actual:
The European Portuguese (pt-PT) keyboard is not found.
  
Expected: 
The European Portuguese (pt-PT) keyboard is found.
  
Flame 2.1 KitKat Base (512mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141002000202
Gaia: 94dcc25f2e34a4900ea58310c26be52bcb089161
Gecko: baaa0c3ab8fd
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
[Blocking Requested - why for this release]:

Shipping locale, please block on this
blocking-b2g: --- → 2.1?
We have pt-BR keyboard layout, need community members to comment what difference we need to make to come out with a pt-PT layout.
Cláudio, could you please comment on if we would need a different keyboard and if so, what the layout should be?
Flags: needinfo?(cesperanc)
Yes, we need a different keyboard for pt-PT, mostly because of the € symbol. 

I've opened a bug a few days ago, with the keyboard layout as a patch for pt-PT but it was probably wrongly categorized by me so no one noticed it. For reference here is the link for this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1074550.

Is this information enough?
Flags: needinfo?(dharris)
Flags: needinfo?(cesperanc)
Attachment #8500083 - Flags: review?(timdream) → review?(rlu)
Duplicate of this bug: 1074550
Comment on attachment 8500083 [details] [review]
Pull request for the missing pt-PT keyboard

Hi Cláudio,

Thanks for the patch.
We've changed the way to define symbol page with bug 1047837.
Please help take a look at the current definition of English or other layouts as an example (find "pages" keyword).

Please help update your patch and let me know if you need any help.

--
Sorry for not seeing your patch in another bug in a timely manner.
In general, we would get notified if you use needinfo or set a review flag to someone.
Attachment #8500083 - Flags: review?(rlu)
Assign to Cláudio first as he got a patch.
Assignee: nobody → cesperanc
Status: NEW → ASSIGNED
Could you rebase the patch? Not the that you are working on other blockers...
Flags: needinfo?(rlu)
Attached file updated Patch
Patch amended to address the comment, will land this afte tree is open and CI passed.
Attachment #8500843 - Flags: review+
Flags: needinfo?(rlu)
Oh, my bad, I didn't realized the tree is closed at the moment. 

You don't really need to wait for CI. The layout is not build by default.
Triage: shipping locale, blocking.
blocking-b2g: 2.1? → 2.1+
Landed,
https://github.com/mozilla-b2g/gaia/commit/347918b27b7572fc8f9700b83a7513e0e8b1220f

--
Thanks for providing the patch!
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S6 (10oct)
Comment on attachment 8500843 [details] [review]
updated Patch

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): for 2.1 product requirement to add pt-PT support.
[User impact] if declined: Cannot have native layout support for Portuguese based in Europe.
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low, layout definition only.
[String changes made]: N/A
Attachment #8500843 - Flags: approval-gaia-v2.1?
(In reply to Rudy Lu [:rudyl] from comment #14)
> Landed,
> https://github.com/mozilla-b2g/gaia/commit/
> 347918b27b7572fc8f9700b83a7513e0e8b1220f
> 
> --
> Thanks for providing the patch!

Thank you for all the work.
This should not be auto uplifted to v2.1, since we changed the format of the layout definition in v2.2.
Whiteboard: [LocRun2.1-1] → [LocRun2.1-1], NO_UPLIFT
(In reply to Rudy Lu [:rudyl] from comment #17)
> This should not be auto uplifted to v2.1, since we changed the format of the
> layout definition in v2.2.

I have a pt-PT layout for v2.1. Do you want me to create a pull request to gaia v2.1 with this or do you prefer I attach the layout file here?
Attachment #8500843 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
(In reply to Cláudio Esperança [:cesperanc@] from comment #18)
> (In reply to Rudy Lu [:rudyl] from comment #17)
> > This should not be auto uplifted to v2.1, since we changed the format of the
> > layout definition in v2.2.
> 
> I have a pt-PT layout for v2.1. Do you want me to create a pull request to
> gaia v2.1 with this or do you prefer I attach the layout file here?

Thanks for offering the help.
I've already landed this to v2.1 with the needed modification.
v2.1,
f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Whiteboard: [LocRun2.1-1], NO_UPLIFT → [LocRun2.1-1]
Verified the issue is fixed on Flame 2.1 and 2.2
Portuguese European presents in Gaia repository with working autocorrection

Flame 2.1
Device: Flame 2.1 KK (319mb Full Flash)
BuildID: 20141022001201
Gaia: 734d3547fb6c65e8bc4dd1a52b26f70bdfee7474
Gecko: 928b18f7d8ff
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.2
Device: Flame 2.2 Master KK (319mb Full Flash)
BuildID: 20141022040201
Gaia: 27a1d1baaa8e375b70e043efee67d5f2206c330b
Gecko: ae4d9b4ff2ee
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.