Closed Bug 1077073 Opened 5 years ago Closed 2 years ago

Display an error when putting a call on hold fails

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: drs, Unassigned)

References

Details

When we attempt to put a call on hold and it fails, there is no error message presented the user. Hsin-Yi has proposed making MozTelephony.hold() and all similar functions return a promise that, when rejected, provides an error message. Once the RIL side of this is implemented, we must handle this in the dialer.
Depends on: 1077075
No longer depends on: 1067883
This is somewhat related to bug 1081028. See bug 1081028 comment 1.
Duplicate of this bug: 1148721
See Also: → 1160325
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.