If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Contacts] Deleting phone number does not take the contact out of ICE contacts

VERIFIED FIXED

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: YeojinC, Assigned: Jose Manuel Cantera)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 verified)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8499129 [details]
logcat_20141002_NotRemovingICEContact.txt

Description:
When the user deletes the phone number of an ICE contact by tapping the number field and selecting the gray X button or by backspace button on the keypad, the contact does not get taken out of the ICE group. The contact remains under ICE contacts.

Pre-requisite: Have a contact with a phone number in Contacts app.

Repro Steps:
1) Update a Flame device to BuildID: 20141002093155.
2) Contacts > Settings > Set ICE Contacts.
3) Add a contact with a phone number under ICE Contact 1 or ICE Contact 2.
4) Select the back button, and Select 'Done'.
5) Select 'ICE contacts' on the main menu.
6) Select the ICE contact, and enter the Edit mode.
7) Tap the phone number field, and delete the phone number by the backspace on the keypad or tapping the gray X icon (NOT the red X icon).
8) Select 'Update'.
9) Select the back button and return to the main menu.

Actual:
Contact is still under ICE contacts with the phone number removed.

Expected: 
Contact is taken out of the ICE contacts.

Note:
When the user deletes the phone number by selecting the red X icon on the left side of the screen on Step 7, the contact is taken out of the ICE contacts properly.

Flame 2.2 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141002093155
Gaia: 191d805f4911628d37a8a90a1e23a6013995138f
Gecko: 5d6ec4dddf14
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Repro frequency: 100%
See attached: logcat,video
http://youtu.be/YcnXAv362sM
See also: https://bugzilla.mozilla.org/show_bug.cgi?id=1073400
(Reporter)

Comment 1

3 years ago
This issue also reproduces on Flame 2.1:

Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141002000202
Gaia: 94dcc25f2e34a4900ea58310c26be52bcb089161
Gecko: baaa0c3ab8fd
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

The contact is still under ICE contacts after the phone number is deleted.
====================================================

Unable to reproduce on Flame 2.0. ICE Contact feature does not exist on v.2.0:

Flame 2.0 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.0
BuildID: 20141002000208
Gaia: 9725d188a733a4aeebcfcf4c52d28e1ad8a2ba6f
Gecko: 05c6a4fed6bc
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Assignee)

Updated

3 years ago
Assignee: nobody → jmcf
QA Whiteboard: [QAnalyst-Triage?] → [ICE][QAnalyst-Triage?]
(Assignee)

Comment 2

3 years ago
Created attachment 8499592 [details]
24756.html

Please note that this patch does not come integration tests, because we have not found a robuts mechanism to simulate all the steps needed to be done by the user.
Attachment #8499592 - Flags: review?(crdlc)
Please ask for 2.1 gaia approval on this bug too
Not nominating to block on this since this issue occurs with specific steps. I don't see this issue effecting a large number of end users.
QA Whiteboard: [ICE][QAnalyst-Triage?] → [ICE][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Comment on attachment 8499592 [details]
24756.html

LGTM, thanks for the patch
Attachment #8499592 - Flags: review?(crdlc) → review+
Merged in master:

https://github.com/mozilla-b2g/gaia/commit/10274b795c4dc7701462cff3bb79f95b20b6384b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → fixed
Resolution: --- → FIXED
Comment on attachment 8499592 [details]
24756.html

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: high because users won't be aware of the contact was an ICE contact deleting the phone number by means of cross reset icon in the input field
[Testing completed]: manual reviewer and developer
[Risk to taking this patch] (and alternatives if risky): close to null, just checking the value of the field
[String changes made]: No
Attachment #8499592 - Flags: approval-gaia-v2.1?
Verify this bug once it lands on 2.1.
Keywords: verifyme
Duplicate of this bug: 1076843
Comment on attachment 8499592 [details]
24756.html

Please renom once you have integration tests.
Attachment #8499592 - Flags: approval-gaia-v2.1?
Tested and working
2.2
Flame
Gecko-c115e55
Gaia-eed1c73
Pending 2.1?

Comment 13

3 years ago
This issue is verified fixed on 2.2 flame 

Removing the phone number from an ICE contact will give user a pop up telling that user cannot have ICE contact without a number and subsequently removes the number from the ICE contacts and turns off the active ICE contact that was tied to the number that was removed.

Flame 2.2
Environmental Variables:
Device: Flame 2.2
Build ID: 20141125040209
Gaia: 824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko: acde07cb4e4d
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)

Updated

3 years ago
QA Whiteboard: [ICE][QAnalyst-Triage+] → [ICE][QAnalyst-Triage?]
QA Whiteboard: [ICE][QAnalyst-Triage?] → [ICE][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #8)
> Verify this bug once it lands on 2.1.

Hi Johan,

The bug has been verified to fail on latest Flame 2.1 build. And we build new Image with the patch, but the bug still exist. Will it land on 2.1?
Flags: needinfo?(jlorenzo)
QA Whiteboard: [ICE][QAnalyst-Triage+] → [ICE][QAnalyst-Triage+],MGSEI-Triage+
Thank for pointing that out Lance.

This bug wasn't a 2.1 blocker and the patch didn't get the approval to go to 2.1 because of the lack of non-regression tests. I think it's too late to get it landed in 2.1. Clearing the verifyme.
Flags: needinfo?(jlorenzo)
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.