Test DMD on TBPL (Mac)

RESOLVED FIXED in mozilla35

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: njn, Assigned: njn)

Tracking

unspecified
mozilla35
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Bug 1073312 will add a DMD test, but not run it on Mac. 10.8 shouldn't be a
problem, but 10.6 is asserting like this after DMD finishes its test mode
invocation:

> Assertion failure: OnLionOrLater() || gCriticalAddress.mAddr != nullptr, at /builds/slave/try-osx64-d-000000000000000000/build/xpcom/base/nsStackWalk.cpp:155

I looked at this briefly, but without access to a 10.6 machine it will be hard
to debug. The best thing might be to add support for running xpcshell tests
only on some Mac versions and then only run the test on 10.8.
(Assignee)

Updated

4 years ago
Depends on: 1077099
Depends on: 1050944
No longer depends on: 1077099
Changed dependency to the bug that actually changed GreD so xrePath points to Contents/Resources. Bug 1050944 had to choose between Contents/Resources/ or Contents/MacOS/ and Contents/Resources/ was chosen. Either choice would cause problems for some people as it has for you. As Stephen stated in bug 1077099 comment #20 you should use GreBinD to get the Gre dir with the binaries or similar method as has been done throughout the codebase to get Mac V2 signing working.
(Assignee)

Comment 2

4 years ago
Created attachment 8501541 [details] [diff] [review]
Enable the DMD test on Mac 10.8

This gets the test working on Mac on Try.
Attachment #8501541 - Flags: review?(mh+mozilla)
Comment on attachment 8501541 [details] [diff] [review]
Enable the DMD test on Mac 10.8

Review of attachment 8501541 [details] [diff] [review]:
-----------------------------------------------------------------

::: memory/replace/dmd/dmd.py
@@ +144,5 @@
>      # This append() call is needed to make the import statements work when this
>      # script is installed as a symlink.
>      sys.path.append(os.path.dirname(__file__))
>  
> +    bpsyms = os.environ.get('BREAKPAD_SYMBOLS_PATH', None)

os.environ.get('BREAKPAD_SYMBOLS_PATH') does the same thing.
Attachment #8501541 - Flags: review?(mh+mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/c20e7032aa3b
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35

Updated

4 years ago
Duplicate of this bug: 1077233
You need to log in before you can comment on or make changes to this bug.