Large file appears to hang browser, but it is just incredibly slow

RESOLVED DUPLICATE of bug 112738

Status

()

P3
major
RESOLVED DUPLICATE of bug 112738
17 years ago
11 years ago

People

(Reporter: hippytrail, Assigned: attinasi)

Tracking

({perf})

Trunk
mozilla1.1alpha
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Loading this file into Mac Mozilla causes the browser to hang or go into an
infinite loop.
The file is the NamesList.txt from Unicode processed to convert all the hex codes
into HTML character entities.
(Reporter)

Comment 1

17 years ago
Created attachment 55900 [details]
Unicode character list - hangs Mac Mozilla

Comment 2

17 years ago
I tryed to view attached document to 20011029-trunk on WinNT4 and Mozilla hanged
too.

Updated

17 years ago
Keywords: hang
confirming with win2k build 20011030..

-> Layout (?)
Assignee: asa → attinasi
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
OS: Mac System 9.x → All
QA Contact: doronr → petersen
Hardware: Macintosh → All
Target Milestone: --- → mozilla0.9.8
(Assignee)

Comment 4

17 years ago
It loads - it is just extremely slow.

Decorating the description and lowering severity.

I'll need to see where we are spending the time here.
Severity: critical → major
Status: NEW → ASSIGNED
Keywords: hang → perf
Priority: -- → P3
Summary: Large file hangs browser → Large file appears to hang browser, but it is just incredibly slow

Comment 5

17 years ago
I think this is a dupe of something dbaron or waterson has worked on.

nsBlockFrame::ReflowFrame is called about once for every line but 
nsBlockFrame::ReflowFrame calls nsLineLayout::ReflowFrame for every line in some 
way so we get a O(n^2) algorithm here.

For 3000 calls to nsBlockFrame::ReflowFrame I see 200000 calls to 
nsLineLayout::ReflowFrame. I don't know about the memory increase though. 

The page is a gigantic <pre> block with some unknown tags in them (<control> 
<music> ... ).
(Reporter)

Comment 6

17 years ago
Created attachment 62733 [details]
Unicode character list - Doesn't hang Mozilla

I noticed that the original attachment was hastily made into HTML by myself.
It contained many angle-bracketed phrases, some of which appeared like bogus
HTML tags, others of which happened to be valid HTML tags.  Notably superscript

and subscript tags.  After converting all of the angle brackets to HTML
entities
the file still takes a long while to load but is now probably acceptable.
The original file may still be useful for optimizing the rendering speed of
Mozilla or perhaps this bug can now be closed?

I think the subscript and superscript tags are the most likely problem in any
case.
(Assignee)

Comment 7

17 years ago
Moving out - not critical.
Target Milestone: mozilla0.9.8 → mozilla1.0

Comment 8

17 years ago
->m1.1
Target Milestone: mozilla1.0 → mozilla1.1

Comment 9

17 years ago
Lage file handling very disappointing...

http://www.mozilla.org/js/language/js20.html

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1) Gecko/20020417
This is basically the same problem as bug 112738, with the same exact issue
(bogo-tags inside a <pre>) (linear content model with O(N) depth, and each
reflow hence being O(N) in the number of nodes).

*** This bug has been marked as a duplicate of 112738 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.