Closed Bug 1077333 Opened 5 years ago Closed 5 years ago

Investigate failure in test_add_to_new_contact_from_messages.py

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: viorela, Assigned: viorela)

Details

Attachments

(2 files)

Attached file logcat
Test test_add_to_new_contact_from_messages.py has failed in latest master build: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.mozilla-central.ui.functional.non-smoke/24/HTML_Report/

Traceback (most recent call last):
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette_test.py", line 264, in run
testMethod()
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/messages/test_add_to_new_contact_from_messages.py", line 46, in test_sms_create_new_contact
new_contact.tap_done(return_contacts=False)
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke/tests/python/gaia-ui-tests/gaiatest/apps/contacts/regions/contact_form.py", line 192, in tap_done
return self.wait_for_done(return_contacts)
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke/tests/python/gaia-ui-tests/gaiatest/apps/contacts/regions/contact_form.py", line 208, in wait_for_done
self.apps.switch_to_displayed_app()
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 88, in switch_to_displayed_app
self.marionette.switch_to_frame(self.displayed_app.frame)
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette.py", line 985, in switch_to_frame
response = self._send_message('switchToFrame', 'ok', element=frame.id, focus=focus)
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/decorators.py", line 35, in _
return func(*args, **kwargs)
File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.ui.functional.non-smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette.py", line 621, in _send_message
"Connection timed out", status=errors.ErrorCodes.TIMEOUT)
TimeoutException: TimeoutException: Connection timed out

The issue is reproducible locally, by running the automated test, but not manually. 
I'm working on getting a regression range.
Trying to find the regression range here, based on b2g-i was difficult, as the test is failing intermittently, and only by running the automated test.
Repro rate: 2 out of 5

I was not able to find a b2g-i build on which this test passed. 
I found the first build on which the test started failing with the error described in this bug. 
In the previous build, the test was failing with a crash for which we asked a back out yesterday. (See Bug 1075136 - Initialize TileClient::mCompositableClient correctly)

Last build the test failed with the crash:
Gaia-Rev        27cbf551e1e9f699b64abc381184515d6483ec43
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/f180d5ed771f
Build-ID        20141002092723
Version         35.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141002.130141
FW-Date         Thu Oct  2 13:01:52 EDT 2014
Bootloader      L1TC10011800

First build the test failed with the error described in this bug:
Gaia-Rev        e678ab4e40bf23bfbb9beb932ce5a048b6523ea9
Gecko-Rev       https://hg.mozilla.org/integration/b2g-inbound/rev/eebf1b565ed3
Build-ID        20141002104317
Version         35.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141002.142009
FW-Date         Thu Oct  2 14:20:23 EDT 2014
Bootloader      L1TC10011800
This issue is not reproducible anymore in the latest master builds.
Also, I ran the test locally and it works as expected.
Assignee: nobody → viorela.ioia
(In reply to Viorela Ioia [:viorela] from comment #2)
> This issue is not reproducible anymore in the latest master builds.
> Also, I ran the test locally and it works as expected.

Actually, this is failing intermittently.
Repro rate, when running the test locally: 1 out of 5. 
I also started an adhoc run: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/183/console
I'll still investigate this issue.
Attachment #8501104 - Flags: review?(zcampbell)
Attachment #8501104 - Flags: review?(robert.chira)
Comment on attachment 8501104 [details] [review]
Github PR: https://github.com/mozilla-b2g/gaia/pull/24890

r-, this will break test_dialer_add_contact where after closing Contacts app it goes back to Dialer app, not Messages.
Attachment #8501104 - Flags: review?(zcampbell)
Attachment #8501104 - Flags: review?(robert.chira)
Attachment #8501104 - Flags: review-
Comment on attachment 8501104 [details] [review]
Github PR: https://github.com/mozilla-b2g/gaia/pull/24890

updated PR, please r?
Attachment #8501104 - Flags: review?(zcampbell)
Attachment #8501104 - Flags: review?(florin.strugariu)
Comment on attachment 8501104 [details] [review]
Github PR: https://github.com/mozilla-b2g/gaia/pull/24890

r+
Attachment #8501104 - Flags: review?(zcampbell)
Attachment #8501104 - Flags: review-
Attachment #8501104 - Flags: review+
Attachment #8501104 - Flags: review?(florin.strugariu) → review?(robert.chira)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
QA Whiteboard: [fxosqa-auto-s1]
You need to log in before you can comment on or make changes to this bug.