"Firefox" is wrongly added to "Open" in the Organize Bar

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Yaron, Unassigned)

Tracking

33 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20140918174809

Steps to reproduce:

An interesting phenomenon:
Whenever I download a file with Firefox, "Firefox" is added to the "Open" list of that file-type in the Organize Bar (or Folder Band) of Windows 7.
For example: I download a PNG file, select the file in Windows Explorer, click on "Open" and "Firefox" is on the top of the list.

I remove the entry with [url=http://defaultprogramseditor.com/]DefaultProgramsEditor[/url], but it reappears after the next download.

http://forums.mozillazine.org/viewtopic.php?f=37&t=2876207
http://forums.mozillazine.org/viewtopic.php?f=38&t=2870531
https://support.mozilla.org/en-US/questions/1021085
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1049521
(Reporter)

Comment 2

4 years ago
Are you sure this is a duplicate of bug 1049521?
In my case, the default program is not changed. "Firefox" is added to the "Open" list.

Comment 3

4 years ago
(In reply to Yaron from comment #2)
> In my case, the default program is not changed.

You're not using Firefox 35 (currently in the Nightly channel).
(Reporter)

Comment 4

4 years ago
Thank you good old Gingerbread Man. :)
(Reporter)

Comment 5

4 years ago
Not resolved in FF 33.

I removed "Firefox" from the "Open" list of ZIP files, downloaded a ZIP file, and "Firefox" is again on the list.
We don't add Windows file associations and I am quite sure this is Windows adding these. I suggest asking in a Windows forum how to get Windows to stop doing this for downloaded files.
Resolution: DUPLICATE → INVALID
(Reporter)

Comment 7

4 years ago
Thanks again. I appreciate it.

Comment 8

4 years ago
Please don't add me to the CC list of bug reports.

I have nothing further to add besides what I said at comment 3. This should be solved in Firefox 35 by bug 1049521, if that's the issue we're dealing with here. It goes without saying that either way, it won't be fixed in the current Firefox 33 or the upcoming Firefox 34.

Methods for remedying this manually have been posted in the following threads. I haven't been able to reproduce the issue since cleaning the registry as indicated.
http://forums.mozillazine.org/viewtopic.php?p=13776539#p13776539
https://support.mozilla.org/questions/1021085#answer-631390
Actually, I uplifted bug 1049521 to Firefox 33 as well as esr31... just look at the flags in bug 1049521. This isn't the same thing as bug 1049521 and comment #6 would be the next step for the reporter,

Comment 10

4 years ago
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #9)
> Actually, I uplifted bug 1049521 to Firefox 33 as well as esr31... just look
> at the flags in bug 1049521.

Yes, I only noticed that after posting the above comment.

> This isn't the same thing as bug 1049521 and comment #6 would be the next step
> for the reporter,

I don't see the point. Like I said, cleaning the registry manually worked for me.
I've provided details on both MozillaZine and Mozilla Support, as noted above.

Somehow, Firefox ended up as a possible handler for types it can't actually handle,
like 7-Zip archives:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.7z\OpenWithList

After cleaning the affected registry keys, the problem hasn't resurfaced.
I've since installed 32.0.3 and then 33.0, and I've downloaded files of
the previously affected types many times.
I haven't seen that except when selecting an application to open a file with in explorer. If you find any clues as to why that is happening please post them to this bug in case there is some way to mitigate that from happening.
(Reporter)

Comment 12

4 years ago
I have thoroughly cleared the relevant registry entries.
I've downloaded image files (png, ico etc.), and, so far, "Firefox" has not been added again to the "Open" list.
However, after downloading ZIP files, "Firefox" is back on the list of that file-type.
(Reporter)

Comment 13

4 years ago
There's actually no difference between ZIP files and other files.
Downloading in a normal window, and "Firefox" is added to the list.
Clearing the registry and downloading in a *private* window - "Firefox" is *not* added to the list.
You need to log in before you can comment on or make changes to this bug.