Call log show 'Voicemail' instead of 'Withheld number'

RESOLVED DUPLICATE of bug 1078663

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 1078663
4 years ago
4 years ago

People

(Reporter: Jørgen Rasmussen, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
I received a call from someone with a withheld number. The call was listed in the call log as Voicemail.
I expected the log to show Withheld number.

Keon with 2.2.0.0 prerelease.
Build identifier: 20140925221803
I'm guessing the voicemail number is unset, and we're having some weird order-of-comparison issue.
Blocks: 1036516
Status: NEW → UNCONFIRMED
Ever confirmed: false
Bug 1078663 has kind of the same results. Did you do an update before noticing this bug, Jørgen?
Flags: needinfo?(joradan0)
(Reporter)

Comment 3

4 years ago
Created attachment 8500953 [details]
call_log.png
Flags: needinfo?(joradan0)
(Reporter)

Comment 4

4 years ago
(In reply to Johan Lorenzo [:jlorenzo] from comment #2)
> Bug 1078663 has kind of the same results. Did you do an update before
> noticing this bug, Jørgen?

No. And I experienced the exact same thing today. See image from Call log. 
I have updated Firefox OS to Build Identifier 20141003223339 between the two calls.
Okay, I reproduced the issue too on master (2.2) with an Orange SIM card. 

Here are the steps to reproduce:
1. Receive a phone call from an unknown phone number => See "Withheld Number"
2. Hang up.
3. Go to call log => See "Voicemail".

This may be linked to bug 1078663. What's your take on this, Doug?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(drs+bugzilla)
Keywords: regression
(In reply to Johan Lorenzo [:jlorenzo] from comment #5)
> This may be linked to bug 1078663. What's your take on this, Doug?

Agreed. Bug 1078663 already has tracking flags and QA on it, so let's move the discussion and simpler STR there.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(drs+bugzilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1078663
You need to log in before you can comment on or make changes to this bug.