closing a window should force it to be hidden until it finishes closing

RESOLVED FIXED in M16

Status

()

Core
XUL
P3
normal
RESOLVED FIXED
19 years ago
a year ago

People

(Reporter: Brade, Assigned: Dan M)

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I'm seeing lots of crashing bugs today (pre-necko) that seem to have to do with
closing windows (whether xul dialogs or main windows).  I'm not sure where this
bug should really land so I'm making a stab with "Views"; please reset/reassign
as necessary.

I think that once the user has started to close the window, the window should be
hidden (if an OS permits) so that the user can't get herself into trouble by
trying to close it a second time or by resizing the window or making some other
action on the window which is partially deleted.

I'm not sure if this is a cross-platform issue or not but it probably shouldn't
be.  I'd guess that we'll run into a bunch of these types of bugs on all
platforms.

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 1

19 years ago
Do you have any reproducible test cases?

Comment 2

19 years ago
Good idea, when a window starts to close, perhaps it should be hidden. I'd say
this is in the XPApps purview.
Assignee: beard → don
Status: ASSIGNED → NEW
Component: Views → XPApps

Updated

19 years ago
QA Contact: beppe → don

Updated

19 years ago
Assignee: don → davidm
Component: XPApps → XP Toolkit/Widgets

Updated

19 years ago
Assignee: davidm → danm

Comment 3

19 years ago
No, I think this is for Dan, the God of Windows. :-)

Seriously, if you can't handle this one, then re-assign it to davidm.
(Assignee)

Updated

19 years ago
Target Milestone: M16

Comment 4

18 years ago
Bad idea, IMHO. If this is implemented, it'll be a lot harder to detect bugs 
involving windows not actually closing when they should.

In addition to which, the extra code will slow down window closing still further.

On 2000021608 build (MacOS 8.6), when you click the close gadget in a window, the 
window goes gray (like a non-frontmost window) and stops accepting any input. 
This WORKSFORME. Couldn't this be done on other platforms too -- just cut off a 
window's input supply?
(Assignee)

Comment 5

18 years ago
While I rather agree with mpt's comment above, windows are nevertheless now being 
hidden at the beginning of their destruction cycle, because of bug 28241.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

17 years ago
QA Contact: don → jrgm
You need to log in before you can comment on or make changes to this bug.