Enable CSS source maps by default

RESOLVED FIXED in Firefox 35

Status

defect
RESOLVED FIXED
5 years ago
Last year

People

(Reporter: harth, Assigned: harth)

Tracking

unspecified
Firefox 35

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

CSS source map support has been in for many releases and many bugs fixed. I think it's time to enable it by default as most people want to see the source they authored and not the generated one.
Assignee: nobody → fayearthur
Attachment #8502614 - Flags: review?(bgrinstead)
^ That patch also makes the inspector context menu item "Show original sources" a checkbox, since seeing "Show CSS sources" would be confusing (I wouldn't know what that meant).
Status: NEW → ASSIGNED
Comment on attachment 8502614 [details] [diff] [review]
CSS source maps on by default

Review of attachment 8502614 [details] [diff] [review]:
-----------------------------------------------------------------

Sounds good to me! Pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=c450255fa707
Attachment #8502614 - Flags: review?(bgrinstead) → review+
Thanks for pushing to try! There was a failure. Turns out sometimes we were displaying the line number in the tooltip for a location link. Small fix so that we always display it.

Try:
https://tbpl.mozilla.org/?tree=Try&rev=3b112b9866d3
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/0218c2f545e8
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 35
Duplicate of this bug: 1002745
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.