Closed Bug 1077677 Opened 5 years ago Closed 5 years ago

Nightly still asks for being made default browser when already set via Windows 10 "You have a new application that can open web pages" notification/prompt

Categories

(Firefox :: Shell Integration, defect)

x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1167294

People

(Reporter: kairo, Unassigned)

References

(Blocks 1 open bug)

Details

When I downloaded Windows 10 Technical Preview, the firs thing I did in the VM was to install Nightly (of course). Ending the installer, Windows presented a prompt that said something like "You have a new application that can open web pages" and that let me set the default browser, so I did that and set it to Nightly right away. When Nightly started up afterwards, it still asked to be made the default browser, even though this was set already.
I think this is by design. I could "reproduce" this even on Win8.1. The protocol association flyout will only set the http association, but Firefox will also check the .html association.
(In reply to Masatoshi Kimura [:emk] from comment #1)
> I think this is by design. I could "reproduce" this even on Win8.1. The
> protocol association flyout will only set the http association, but Firefox
> will also check the .html association.

Yep. Click yes to the dialog or set fx as the default through options.
Component: General → Shell Integration
Kairo, do you know a way to reset this so that it reappears after I uninstall Nightly and then reinstall Nightly? I'd like to fix this, but I won't know if it is fixed unless I can verify.

I looked at the code here and it always passes in `false` for claimAllTypes, which matches the value used when setting the default browser for Windows 8+.

Kairo, can you also retest on a build that has the patches from bug 1167294?
Flags: needinfo?(kairo)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #3)
> Kairo, do you know a way to reset this so that it reappears after I
> uninstall Nightly and then reinstall Nightly?

Unfortunately not.

> Kairo, can you also retest on a build that has the patches from bug 1167294?

I don't really know how I can retest. :(

KaiRo
Flags: needinfo?(kairo)
To test:
1) Open 'Modern application' press the Windows key, type settings, select Settings
2) Select System
3) Select Default apps
4) Set Web browser back to another browser such as Project Spartan.

I just tested with nightly, the Setting windows is brought up but the user must set the default browser manually.
> the Setting windows is brought up but the user must set the default browser manually.

It is by design. Windows 8+ disallows apps to set the default browser programatically. We can do nothing about the dictatorship of Microsoft :(
And it has nothing to do with this bug.
Yep. I added the steps to reset the default browser to allow verification and added the expected results for others that look for this bug. I should have labels the expected results.
This should be fixed now, with uplifts going to aurora and maybe beta on some of the other related bugs. See bug 1167294 for more details.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1167294
You need to log in before you can comment on or make changes to this bug.