Can't customizing build-time apps

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Build
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Raniere Silva, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Steps to reproduce:

Follow the steps at https://developer.mozilla.org/en-US/Firefox_OS/Developing_Gaia/Customizing_build-time_apps.

Starting from 5993c5953c7e4ffc6f424f9b8174566256c9ba02 I made the change

diff --git a/build/config/tablet/apps-production.list b/build/config/tablet/apps-production.list
index 7174809..951e77b 100644
--- a/build/config/tablet/apps-production.list
+++ b/build/config/tablet/apps-production.list
@@ -22,3 +22,4 @@ apps/system
 apps/video
 apps/wallpaper
 outoftree_apps/*
+external-apps/*

And

$ ls -1 external-apps 
abfb2reader/
basicbasic/
cuttherope/
epubreader/
filemanager/
firetext/
fruitcutninja/
gameboy/
gboyemulator/
marketplace.firefox.com/
notes/
pdfviewer/
plotly/
pokquiz/
texteditor/

After I compile with

$ DEVICE_DEBUG=1 REMOTE_DEBUGGER=1 NOFTU=1 NO_LOCK_SCREEN=1 PRODUCTION=1 GAIA_DEVICE_TYPE=tablet make reset-gaia

Actual Results:

No extra app.
	 
Expected Results:

Extra app installed.
(Reporter)

Comment 1

3 years ago
This is probably related with

Exception: Error: "external" property in metadata.json is required since Firefox OS 2.1, please add it into meta data.json and update preload.py if you use this script to perload your apps.
(Reporter)

Comment 2

3 years ago
Upgrade preload.py solve the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.