Please deploy release 0.12.3 to loop-server Production

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: rpapa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
Depends on: 1076905

Comment 1

4 years ago
I've deployed this to production and it can be seen at https://bugzilla.mozilla.org/show_bug.cgi?id=1077777. rpapa can you have a basic look and if it appears fine I'll swap production DNS over to point at this.
Status: NEW → ASSIGNED
Thanks, Dean! (glad you're feeling better)

Initial quick check on:
https://loop-server-20-elb-5ov030lbwrb6-654042815.us-west-2.elb.amazonaws.com/

HTTP/1.1 200 OK
Date: Wed, 08 Oct 2014 16:49:37 GMT
Content-Type: application/json; charset=utf-8
Content-Length: 321
Connection: keep-alive
ETag: W/"141-338cb29e"
Timestamp: 1412786977


That's about all I can check until you cut it over.  Once you've changed DNS, needinfo me and I'll do final verification on https://loop.services.mozilla.com/.
Flags: needinfo?(dwilson)

Comment 4

4 years ago
I've now repointed the DNS to this stack in production so it's live.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(rpappalardo)
Resolution: --- → FIXED
QUICK CHECKS

4-5 calls between Nightly and Aurora without incident.

A quick 'make test' against 0.12.3 has some errors:
http://pastebin.mozilla.org/6750087

Alexis - do we need to be concerned with these?


If not, I'll go ahead and verify.

https://loop.services.mozilla.com/
{"name":"mozilla-loop-server","description":"The Mozilla Loop (WebRTC App) server","version":"0.12.3","homepage":"https://github.com/mozilla-services/loop-server/","endpoint":"https://loop.services.mozilla.com","fakeTokBox":false,"fxaOAuth":true,"i18n":{"defaultLang":"en-US","lang":"en-US"}}

$ curl -I https://loop.services.mozilla.com
HTTP/1.1 200 OK
Date: Thu, 09 Oct 2014 17:04:21 GMT
Content-Type: application/json; charset=utf-8
Content-Length: 277
Connection: keep-alive
ETag: W/"115-84537797"
Timestamp: 1412874261
Flags: needinfo?(alexis+bugs)
re-running the tests should make them pass, we have them sometimes, due to how they're written, no big deal.
Flags: needinfo?(alexis+bugs)
Thanks for letting me know, Alexis.  re-ran them several times yesterday and saw those failures, but they all pass when I ran them today.

No negative feedback from release. Closing this ticket.
Status: RESOLVED → VERIFIED
Flags: needinfo?(rpappalardo)
Flags: needinfo?(dwilson)
You need to log in before you can comment on or make changes to this bug.