Email address completion - pressing Enter after cursor-right changes selected address

RESOLVED DUPLICATE of bug 1043310

Status

RESOLVED DUPLICATE of bug 1043310
4 years ago
4 years ago

People

(Reporter: bdimm, Unassigned)

Tracking

({regression})

31 Branch
x86_64
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 2014082900

Steps to reproduce:

1) Type "aron" into the "To" field, address completion drop-down shows a person named Sharon in the first position (really not ideal) and shows the person named Aron in the second position.  Press cursor-down twice to move to Aron's name.
2) Press cursor-right and Aron's full name and email address are filled in for the "To" field.
3) Press Enter or Tab to move to the next field.


Actual results:

 After step (3), Aron's name and email address is replaced by Sharon's in the To field!

Note: This does not happen if you press Enter or Tab immediately after pressing cursor-down to select the desired name from the list.  It is only when you hit cursor-right before hitting Enter or Tab that things go haywire.

While your response might be "so, don't press cursor-right," I seem to have become subconsciously trained to do so by either a previous version of Thunderbird or some website like Google.  I double I am the only person now (if this happened with previous versions of Thunderbird, I never noticed it before) habitually sending emails to the wrong person because of this weird behavior.


Expected results:

The name that was visible on the "To" line should have stayed as-is when Enter or Tab was pressed, rather than being replaced by the first name from the auto complete list.

Comment 1

4 years ago
Fix is in bug 1043310
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1043310

Comment 2

4 years ago
Created attachment 8531284 [details] [diff] [review]
Set forcecomplete to false for autocomplete input

I don't think this issue should be put to one huge Bug 1043310. There are multiple issues with autocomplete and correcting them all in one piece would be very hard. I think we should correct them one at a time - this would make it much easier to review it and get patches accepted.

This is proposed patch for this particular, serious issue:
- choose autocomplete entry other than first;
- accept using RIGHT or LEFT key
- change focus using ENTER or TAB
- first entry would be entered instead, mail goes to wrong person.

I think this is caused by forcecomplete='true' attribute set (left default?) for this input. setting forcecomplete='false' in contructor makes this bug go away.

Please reopen this bug and review this one-liner patch.
Attachment #8531284 - Flags: review?(mkmelin+mozilla)

Comment 3

4 years ago
Comment on attachment 8531284 [details] [diff] [review]
Set forcecomplete to false for autocomplete input

Review of attachment 8531284 [details] [diff] [review]:
-----------------------------------------------------------------

Thx for the patch, but we do want forceComplete true. Not having it can fix that particular case, but also break other cases (like not using capitalization according to contact properties)
Attachment #8531284 - Flags: review?(mkmelin+mozilla) → review-
You need to log in before you can comment on or make changes to this bug.