Java-based stock quote streaming windows don't work

RESOLVED INVALID

Status

Core Graveyard
Java: OJI
--
major
RESOLVED INVALID
16 years ago
7 years ago

People

(Reporter: Brian P. Poi, Assigned: Joe Chou)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    2001101202

Once you log into this (free) site, it launches a Java app that provides you
with a window that provides streaming real-time stock quotes and another window
with a stock chart that updates in real-time also.  Mozilla draws part of the
stock quote window and makes a white box where the chart should go, but then it
basically freezes up and does not respond.  I had been using this website w/
Netscape 4.76, and most of the time it worked fine (occassionally Netscape would
lock up and need to be forcefully killed).

Reproducible: Always
Steps to Reproduce:
1.go to www.scottrader.com
2.(First time) Create a user account (free)
3.Log in

Actual Results:  The stock quote display window would partially draw itself and
then freeze up.  The stock chart window remained all white.  The only recourse
is to kill Mozilla.

Expected Results:  Loaded a stock quote display window with about 10 stock
symbols programmed in.  Quotes, bids, offers, tick patterns, etc. should update
automatically as trades occur.

I put this as critical severity because I would guess it affects other web sites
which try and stream data in a similar manner (e.g. datek.com), and because this
website provides time-critical data.
Reporter: Have you tried the instructions in the release notes?
http://www.mozilla.org/releases/mozilla0.9.5/#java

Also, there is a known compatibility problem between mozilla, the Sun JRE 1.3.0
plugin and the 2.4 kernel with RH 7.1. For details, see:
http://bugzilla.mozilla.org/show_bug.cgi?id=84093 

Workaround: Upgrade your Java plugin to at least JRE 1.3.1 or set this
enviornment variable before starting mozilla: LD_ASSUME_KERNEL=2.2.5

-> OJI
-> major
Severity: critical → major
Component: Browser-General → OJI

Comment 2

16 years ago
->OJI
Assignee: asa → joe.chou
QA Contact: doronr → pmac

Comment 3

16 years ago
I failed to create test account at scottraider
(i have filed number of online forms but i only got 
 email with rejection of account creation  
 - because i am not US citezen!).

Without test account there is no way to reproduce the problem.

Could someone create a test account there and post 
here details on it? 

If we will be unable to reproduce the problem then we 
can not fix it and will close this bug as INVALID.

Comment 4

16 years ago
Resolving invalid due to a lack of response. Please reopen if this can be
reproduced in a moz > 1.0RC1 with a JRE 1.4+.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 5

15 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: joe.chou → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.