Closed Bug 1078116 Opened 5 years ago Closed 5 years ago

Build output freezes in Windows 10

Categories

(Firefox Build System :: General, defect)

All
Windows 10
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: gps, Unassigned)

References

Details

I installed the Windows 10 technical preview in a VM. MozillaBuild appeared to install just fine. Was able to `hg clone` m-c without issue.

When I went to run `mach configure`, output to cmd.exe paused after a few minutes. Strangely, clicking around cmd.exe or entering arrow keys would cause a single line of text to be drawn after a click every 1-2s or so or would result in program resumption. `mach build` exhibited similar issues. Hitting ^C would seemingly cause things to become unstuck for a while. Although it was unclear after a few attempts if anything actually got killed.

I have no clue what is going on here. It feels like something very low level dealing with pipes and buffering. I wouldn't be surprised if there is a Python or cmd.exe compatibility issue (cmd.exe is brand new and supports things like proper copy/paste and resizing). MozillaBuild's additional terminal interaction and bash adds their own points of failure.

Until this is fixed or worked around, I dare say developing Firefox on Windows 10 is a non-starter: constantly attending to cmd.exe is just too annoying.
Blocks: windows-10
This also happens with some hg actions for me. I haven't tried, but maybe disabling the experimental "Ctrl" shortcuts will work ?
(In reply to Blair McBride [:Unfocused] from comment #1)
> As a workaround, to get builds working working nicely on Windows 10 right
> now, using MinTTY works. 

Good to know. I was planning to switch to that by default for the next major release anyway.
Depends on: 505582
Removing from the general product Windows 10 tracking bug, as this isn't a Firefox issue.
No longer blocks: windows-10
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #3)
> (In reply to Blair McBride [:Unfocused] from comment #1)
> > As a workaround, to get builds working working nicely on Windows 10 right
> > now, using MinTTY works. 
> 
> Good to know. I was planning to switch to that by default for the next major
> release anyway.

At what point might we expect this change? :-)
Flags: needinfo?(ryanvm)
I posted a release candidate build today. Barring any last-second issues, this is the build that will be shipped as the final release:
http://people.mozilla.org/~rvandermeulen/MozillaBuildSetup2.0.0RC1.exe
Flags: needinfo?(ryanvm)
Note that while mintty is being included with the upcoming release, it'll be disabled by default. It's simple to enable, though (just setting a 1 in the right place).
I don't think I see this on Windows 10 anymore.
I did a fresh Win10 build 10130 install in a VM today with the RC build in comment 6 and MSVC2015 RC and also can't reproduce. So I guess this was fixed one way or another. Maybe it was a bug in an earlier preview release or something.

Greg, can you confirm that this works for you as well now?
Flags: needinfo?(gps)
I built without freezing with mozillabuild 1.11, as did dolske, AIUI, so going to mark this WFM based on that. Leaving n-i in case gps wants to comment still.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
I don't think there's much I can add: the problem appears fixed. Probably a bug in a pre-release OS :)
Flags: needinfo?(gps)
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.