Closed Bug 1078177 Opened 5 years ago Closed 4 years ago

Intermittent test_click_scrolling.py TestClickScrolling.test_clicking_on_anchor_scrolls_page | TimeoutException: TimeoutException: Error loading page, timed out (checkLoad)

Categories

(Testing :: Marionette, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: cbook, Unassigned)

References

()

Details

(Keywords: intermittent-failure, pi-marionette-intermittent)

b2g_emulator_vm b2g-inbound opt test marionette

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=590674&repo=b2g-inbound

20:28:20 ERROR - TEST-UNEXPECTED-ERROR | test_click_scrolling.py TestClickScrolling.test_clicking_on_anchor_scrolls_page | TimeoutException: TimeoutException: Error loading page, timed out (checkLoad)
This appears to have been caused by something that landed on both b2g-inbound (and was merged to mozilla-central, etc., from there) and mozilla-aurora.  I'm doing some retriggers on b2g-inbound to narrow down the range, although problems with missing b2g-35.0a1.en-US.android-arm.tests.zip may put a damper on that.
This is essentially permafail on trunk and ~50% failure rate on b2g34.
Have retriggered Mn a bunch of times will check back!
Should I go ahead and disable this on trunk & b2g34?
Flags: needinfo?(dburns)
Sure... I dont have the time to look into this. Goddamn emulator is a pile of poo
Flags: needinfo?(dburns)
I pushed to try with this disabled the other day to see if it gets us in a visibility-acceptable range for the emulator Mn here:

https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=ffd73601530e

Unfortunately, I don't think it does: 5/21 retriggers were orange on that push.