Closed Bug 1078226 Opened 5 years ago Closed 5 years ago

Unexpected Audio Level indicator on audio-only calls, also disable broken low-quality video warning indicator

Categories

(Hello (Loop) :: Client, defect)

defect
Not set
Points:
1

Tracking

(firefox33 unaffected, firefox34+ fixed, firefox35 verified, firefox36 verified)

VERIFIED FIXED
mozilla36
Iteration:
36.1
Tracking Status
firefox33 --- unaffected
firefox34 + fixed
firefox35 --- verified
firefox36 --- verified
Blocking Flags:
backlog Fx34+

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Keywords: regression)

Attachments

(2 files)

Looks like upgrading the sdk to version 2.2.9 introduced this unexpectedly, bug 1066219 didn't comment about it, but the release notes did, hence it looks like we missed it.

Looks like we need to set style.audioLevelDisplayMode to "off" when defining the publisher configuration mode.

Additionally, we should probably set "videoDisabledDisplayMode" to "off" as well, from the docs:

=== Docs ===
Whether to display the video disabled indicator and video disabled warning icons for a Subscriber. These icons indicate that the video has been disabled (or is in risk of being disabled for the warning icon) due to poor stream quality. 
=== End Docs ===

For now the images are broken, but tbh, I don't think they adequately explain what is going on. Additionally, the function only works if we are connected via the media router, which we try and avoid at the moment.

Hence, I think we should probably just disable it as well.
Blocks: 1066219
Darrin: This is a before & after the disabling of the audio meter. If we want to keep the OpenTok version, that's fine. I can just keep it there. If we want to implement a different version, then we should probably disable what we've got and file a new bug to be implemented which would handle the appropriate UX.
Assignee: nobody → standard8
Status: NEW → ASSIGNED
Attachment #8501618 - Flags: ui-review?(dhenein)
Changes the config settings. Waiting to request review pending ux-review results.
Target Milestone: --- → mozilla35
Comment on attachment 8501618 [details]
Before and after audio indicator disabled

I don't think we want to use the OpenTok version, so let's hide it for now. We can open a new bug to prioritize/design our own audio indicator UI.
Attachment #8501618 - Flags: ui-review?(dhenein) → ui-review+
Comment on attachment 8501622 [details] [diff] [review]
Unexpected Audio Level indicator on audio-only calls for Loop, also disable broken low-quality video warning indicator.

Somehow I'd missed the ui-review+. Anyway, the patch still applies, so must be time for review.
Attachment #8501622 - Flags: review?(nperriault)
Comment on attachment 8501622 [details] [diff] [review]
Unexpected Audio Level indicator on audio-only calls for Loop, also disable broken low-quality video warning indicator.

Review of attachment 8501622 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #8501622 - Flags: review?(nperriault) → review+
https://hg.mozilla.org/integration/fx-team/rev/92bacff87c21
Iteration: --- → 36.1
Points: --- → 1
Target Milestone: mozilla35 → mozilla36
https://hg.mozilla.org/mozilla-central/rev/92bacff87c21
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Flags: qe-verify-
Comment on attachment 8501622 [details] [diff] [review]
Unexpected Audio Level indicator on audio-only calls for Loop, also disable broken low-quality video warning indicator.

Approval Request Comment
[Feature/regressing bug #]: bug 1066219 (upgrade of sdk)
[User impact if declined]: Unwanted artefacts on display.
[Describe test coverage new/current, TBPL]: Tested locally, not able to test in automation. Tests for rest of functionality still pass.
[Risks and why]: Low - disabling features by passing arguments to third party sdk.
[String/UUID change made/needed]: None
Attachment #8501622 - Flags: approval-mozilla-beta?
Attachment #8501622 - Flags: approval-mozilla-aurora?
backlog: --- → Fx34+
The audio level indicator is gone now.
Tested on the dev-server using 36.0a1 (2014-10-17) Win 7 x64.
Status: RESOLVED → VERIFIED
Comment on attachment 8501622 [details] [diff] [review]
Unexpected Audio Level indicator on audio-only calls for Loop, also disable broken low-quality video warning indicator.

Beta+
Aurora+
Attachment #8501622 - Flags: approval-mozilla-beta?
Attachment #8501622 - Flags: approval-mozilla-beta+
Attachment #8501622 - Flags: approval-mozilla-aurora?
Attachment #8501622 - Flags: approval-mozilla-aurora+
Tested and good on Aurora nightly build; windows and linux.
You need to log in before you can comment on or make changes to this bug.